#4 rpm-installation: libGLcore missing

open
nobody
None
5
2002-03-18
2002-03-18
Anonymous
No

Hi,

as compiling failed at me, too, I asked a friend to
help me installing kxicq2. He gave me a rpm-package,
but now I have another error:
------------------------------
$rpm -Uvh kxicq2-0.7.7-0.i386.rpm
Fehler: fehlgeschlagene Paket-Abhängigkeiten:
libGLcore.so.1 wird von kxicq2-0.7.7-0 gebraucht
------------------------------
Translation: missing dependeny: libGLcore.so.1 is
needed to install kxicq2

The problem is, I HAVE libGLcore.so.1 and I made
symbolic links to it in /opt/kde2/lib, /usr/X11R6/lib
and /usr/lib (here is the one, all are linked to:
libGL.so.1 which is also linked to the real driver file
in /usr/lib/GL)

Why doesn't he know that the package is already installed?

Thorsten

Discussion

  • Dominic Battre
    Dominic Battre
    2002-04-02

    Logged In: YES
    user_id=333247

    -U means upgrade.
    Maybe you should try rpm -ihv kxicq2-0.7.7-0.i386.rpm (-i ==
    install) or use --nodeps (disables dependency check), if you
    really want to upgrade.

    Nevertheless I suggest using the CVS-version (sourcecode) as
    the rpm is kind of outdated.

     
  • Logged In: NO

    I got a libGLcore error too, then I installed with
    rpm --install KXicq2~~~.rpm --nodeps
    and it worked OK.