kwave won't save

Help
2002-10-24
2012-09-30
  • Sander Hulst
    Sander Hulst
    2002-10-24

    Hi Thomas,

    I tried the kwave editor, and it looks very promising. Unfortunatly I cannot save a single thing. This is what is says:
    ----
    [hulst@moebius tmp]$ kwave
         amplifyfree   2.0 written by Thomas Eschenbacher
               about   2.0 written by Ralf Waspe
    codec_audiofile   2.0 written by Thomas Eschenbacher
           codec_wav   2.0 written by Thomas Eschenbacher
              memory   2.0 written by Thomas Eschenbacher
           newsignal   2.0 written by Thomas Eschenbacher
               noise   2.0 written by Thomas Eschenbacher
            playback   2.0 written by Thomas Eschenbacher
         selectrange   2.0 written by Thomas Eschenbacher
            sonagram   2.0 written by Thomas Eschenbacher
                zero   2.0 written by Thomas Eschenbacher
    ---
    found 11 plugins
    ASSERT: "params.count() == 6" in MemoryPlugin.cpp (51)
    MemoryPlugin::interpreteParams(): params.count()=0
    ASSERT: "params.count() == 4" in PlayBackPlugin.cpp (113)
    PlayBackPlugin::interpreteParams(): params.count()=0
    [hulst@moebius tmp]$ Mutex destroy failure: Device or resource busy
    kdeinit: Fatal IO error: client killed
    kdeinit: sending SIGHUP to children.
    TopWidget::executeCommand(): loading plugin 'newsignal'
    TopWidget::executeCommand(): with 0 parameter(s)
    kdeinit: sending SIGTERM to children.
    kdeinit: Exit.
    PluginManager: command='plugin:execute(newsignal, 198450, 22050, 16, 2, 1)'
    SignalManager::setModified(1)
    SignalManager::save(file:/tmp/euh.wav) - [audio/wav] (16 bit, selection=0)
    SignalManager::save(): res=-124
    SignalManager::setModified(0)
    KwaveApp::closeWindow(TopWidget *todel)
    ---------
    I'll try and find out what Mutex is :)

    Sander

     
    • Hi Sander,

      I don't think that this has something to do with a mutex, AFAIK this message doesn't come from Kwave itself. The relevant error code is in the last three lines. "-124" means ERR_MEDIUMTYPE and comes only when an encoder (or decoder) plugin could not be found.

      Maybe there was a problem detecting which encoder should be used for a given mime type. You should get a message box  with the text "Sorry, the file type is not supported!", right?

      What happens if you choose to save under a different file format or into a different directory?

      Please also check if you really have write permissons in the directory where you want to save and it's partition is not full.

      BTW: /tmp is also the directory where temporary files are stored. You should go to Options/Memory and configure virtual memory stuff (and also Options/Playback).

      Thomas

       
    • Sander Hulst
      Sander Hulst
      2002-11-05

      Hi,

      sorry that it took so long to reply.

      From what you say, and the fact that .wav is the only type I can save as (on the writable /tmp dir :), I guess I have a problem with the encoder. Indeed I get a 'filetype not supported'. I checked real/ virtual memory, that looked ok with 64/256 Mb.

      This is my .wav meta info:
      -------------------------
      wav header:
      mode        = 0x0001, ( Microsoft PCM format )
      channels    = 2
      rate        = 44100
      bytes/s     = 176400
      block align = 4
      bits/sample = 16
      -------------------------
      -------------------------
      info:
      channels    = 2
      rate        = 44100
      bits/sample = 16
      length      = 2460419 samples
      format      = 401 (linear two's complement)
      -------------------------
      SignalManager::save(file:/home/hulst/somethingnew.wav) - [audio/wav] (16 bit, selection=0)
      SignalManager::save(): res=-124
      ---------------------------

      What encoder should I have? Sox, right?

       
      • the decoder I am talking of is a built-in Kwave plugin (codec_wav), and not some external program like sox.

        I currently have no idea why it fails. But you can update to v0.6.5 that I will release this weekend and see if the problem disappears...

         
    • S. Georgaras
      S. Georgaras
      2003-03-23

      hi all

      I have been using v0.6.6 the last couple of days, and I have the same problem.

      When I use the "Save as.." dialog I get the "Sorry, the file type is not supported!" msg although the filename field displays the original filename.

      I have noticed that If I click a file name in the file list and then change the filename to the desired, everything works ok!

      The above applies to wav files...

      Hope this helps

       
      • I had a similar case some weeks ago with a user who had a broken mime type setup. Do you see a message with [audio/wav] on the console?

        If yes, then you most probably you have an old .kdelnk or .desktop file somewhere on your system that specifies that mime tpye. Please note that "audio/wav" is no official mime type and it would be best to eliminate all .desktop files that define it.

        Can you please do the following:

        1. tell me which distribution you use

        2. call "updatedb"

        3. type "locate .desktop | grep wav" and look into all the files that are found if they define audio/wav. If yes - remove them or move them away.

         
    • S. Georgaras
      S. Georgaras
      2003-03-24

      Hi Thomas,
      I have seen some msgs with "audio/wav" on the console, but I don't know if this is what you mean. So this is the output...

      SignalManager::loadFile(file:/home/spiros/cd/24.Tzeni_Vanou_-_Thelo_konta_sou_na_meino.wav) - [audio/x-wav]
      scanning for chunks in '/RIFF' (format='WAVE'), offset=0x0000000C, length=31403740
      --- RIFF file structure after first pass ---
      [0x00000000-0x01DF2EE7] (  31403752/  31403752)    ROOT, ''
      [0x00000000-0x01DF2EE7] (  31403744/  31403744)    MAIN, '/RIFF (WAVE)'
      [0x0000000C-0x00000023] (        16/        16)     SUB, '/RIFF/fmt '
      [0x00000024-0x01DF2EE7] (  31403708/  31403708)     SUB, '/RIFF/data'
      fmt chunk starts at 0x00000014
      data chunk at 0x0000002C (31403708 byte)
      -------------------------
      wav header:
      mode        = 0x0001, ( Microsoft PCM format )
      channels    = 2
      rate        = 44100
      bytes/s     = 176400
      block align = 4
      bits/sample = 16
      -------------------------
      --- dump of file info ---
      default properties:
         length = 7850927 samples
         rate   = 44100.0 Hz
         bits   = 16
         tracks = 2
      other properties:
         'Compression' = '0'
         'Filename' = '/home/spiros/cd/24.Tzeni_Vanou_-_Thelo_konta_sou_na_meino.wav'
         'File Size' = '31403752'
         'Mime Type' = 'audio/x-wav'
         'Sample Format' = '401'
      -------------------------
      SignalManager::setModified(1)
      TopWidget::saveAs(file:/home/spiros/cd/24_2.Tzeni_Vanou_-_Thelo_konta_sou_na_meino) - [application/octet-stream] (previous:'audio/x-wav')
      mimetype = application/octet-stream
      FileInfoDialog::accept()
      --- dump of file info ---
      default properties:
         length = 7850927 samples
         rate   = 44100.0 Hz
         bits   = 16
         tracks = 2
      other properties:
         'Compression' = '0'
         'Filename' = 'file:/home/spiros/cd/24_2.Tzeni_Vanou_-_Thelo_konta_sou_na_meino'
         'File Size' = '31403752'
         'Mime Type' = 'application/octet-stream'
         'Sample Format' = '401'
      -------------------------
      FileInfoDialog::accept() --2--
      --- dump of file info ---
      default properties:
         length = 7850927 samples
         rate   = 44100.0 Hz
         bits   = 16
         tracks = 2
      other properties:
         'Filename' = 'file:/home/spiros/cd/24_2.Tzeni_Vanou_-_Thelo_konta_sou_na_meino'
         'File Size' = '31403752'
         'Mime Type' = 'application/octet-stream'
         'Sample Format' = '401'
      -------------------------
      SignalManager::save(file:/home/spiros/cd/24_2.Tzeni_Vanou_-_Thelo_konta_sou_na_meino) - [application/octet-stream] (16 bit, selection=0)
      WARNING: KDE detected X Error: BadMatch (invalid parameter attributes) \x08
        Major opcode:  *
      SignalManager::save(): res=-124

      Does this help?

       
      • Yes, that's what I meant first!

        But from what I see, you should never see that "application/octett-stream", which means that you have not recognized any mime type at all, or selected nothing in the file type combo box of the SaveAs dialog. It has the same reason: your mime type setup is broken. And the same solution: find and eliminate all .desktop files that seem to be responsible for the *.wav mime type or the *.wav mime type except one and then fix this one.

         
    • S. Georgaras
      S. Georgaras
      2003-03-24

      Oh, sorry
      I forgot to tell you I'm using SuSE 7.3