kde kwave unresolved dependecies

Help
sixtyhz
2005-07-22
2012-09-30
  • sixtyhz
    sixtyhz
    2005-07-22

    Hi. I'm a linux newbie and know a little about c/l. I have managed to install a few apps by hook or by crook but am confused about different install/compile/make.
    OK I have I686 , Kernal 2.6.0-21, kde version 3.1.5 turbolinux 10
    I have tried to install Kwave rpm kwave-0.6.4-1-SuSE-KDE3.i386.rpm

    Q 1 does the make number have to match ie will i386.rpm work on i686 sys?
    Q2 I get this error on install
    List of unresolved dependencies
    libfam.so0 by kwave
    libqt.so.2 by kwave
    where can i get these files and where should i put/install them?
    Hope this makes sence to someone.
    thanks.
    nick.

     
    • sixtyhz
      sixtyhz
      2005-07-24

      Ok heres is what happened in console.
      [tricky@localhost tricky]$ ls
      Desktop/ Installers/ kwave-0.7.3-1.src.rpm Mail/ mp3/ MyDocument/
      [tricky@localhost tricky]$ rpm --rebuild kwave-0.7.3-1.src.rpm
      kwave-0.7.3-1.src.rpm: No such file or directory
      [tricky@localhost tricky]$ rpmbuild --rebuild kwave-0.7.3-1.src.rpm
      bash: rpmbuild: command not found
      [tricky@localhost tricky]$ rpm --rebuild kwave-0.7.3-1.src.rpm
      kwave-0.7.3-1.src.rpm: No such file or directory
      [tricky@localhost tricky]$

      but if i remove -- and have rpm rebuild kwave-0.7.3-1.src.rpm it seems to do somthing and gives me a usage list but i dont know what to do next.
      thanks again for your patience.
      nick.

       
      • Nick, just to be sure: you need to do all this as root, not as normal user!

        Additionally, it seems that you have to install the packages "rpm-build" and maybe "rpm-devel" too under Turbolinux.

        (I have no Turbolinux system here, so it's a bit difficult to reproduce your problems...)

         
    • Hi Nick,

      it's always problematic if you try to install a binary package from one distribution into another.

      So IMO the best way for you should be to take the src.rpm and try to gererate the binary package on your own. Wel, you will have to install some additional (devel) packages too, but afterwards you have a rpm package that really fits to your distribution ;-)

      So please fetch the latest sec.rpm and try:
      rpmbuild --rebuild kwave-0.7.3-1.src.rpm

      If you have problems that you cannot solve by reading the README file, then fell free to ask again!

      Thomas

       
    • sixtyhz
      sixtyhz
      2005-07-23

      Hi Thomas
      ok this make sence for the most part but what does sec.rpm mean?
      I really am a total dum dum when it comes to linux.
      I cant even get this forum to mail me when there is a responce.
      thx nick

       
    • sixtyhz
      sixtyhz
      2005-07-23

      ok I have d/l the latest src.rpm
      I presume you mean to run these commands in the console.
      Which i have run
      Logged in as root and changed directory to the file.

      rpmbuild --rebuild kwave-0.7.3-1.src.rpm

      it said bad command

      I also tried rpm build with no luck.
      thx again.
      nick

       
      • ... that depends on the "rpm" your distribution uses.

        Some (newer) use:
        rpmbuild --rebuild <filename>.src.rpm

        and some others still use:
        rpm --rebuild <filename.src.rpm>

        Thomas.