Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Tree [19cc8d] Release-0_5_2 /
History



File Date Author Commit
bin 2000-04-02 Thomas Eschenbacher Thomas Eschenbacher [2a1cc1] checkin of historic release 2000-04-03-v0.5.1-3
libgui 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
plugins 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
po 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
src 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
CHANGES 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
GNU-LICENSE 1998-12-12 Martin Wilz Martin Wilz [429088] checkin of historic release 1998-12-13-v0.29-pre2
Makefile.am 2000-04-02 Thomas Eschenbacher Thomas Eschenbacher [2a1cc1] checkin of historic release 2000-04-03-v0.5.1-3
Makefile.dist 2000-02-03 Thomas Eschenbacher Thomas Eschenbacher [1e7d67] checkin of historic release 2000-02-04-v0.5.0-15
README 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
TODO 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
VERSION 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
acconfig.h 2000-02-03 Thomas Eschenbacher Thomas Eschenbacher [1e7d67] checkin of historic release 2000-02-04-v0.5.0-15
acinclude.m4 2000-04-02 Thomas Eschenbacher Thomas Eschenbacher [2a1cc1] checkin of historic release 2000-04-03-v0.5.1-3
aclocal.m4 2000-04-02 Thomas Eschenbacher Thomas Eschenbacher [2a1cc1] checkin of historic release 2000-04-03-v0.5.1-3
automoc 2000-02-03 Thomas Eschenbacher Thomas Eschenbacher [1e7d67] checkin of historic release 2000-02-04-v0.5.0-15
config.guess 2000-02-03 Thomas Eschenbacher Thomas Eschenbacher [1e7d67] checkin of historic release 2000-02-04-v0.5.0-15
config.h.bot 1998-12-12 Martin Wilz Martin Wilz [429088] checkin of historic release 1998-12-13-v0.29-pre2
config.h.in 2000-03-03 Thomas Eschenbacher Thomas Eschenbacher [4f692d] checkin of historic release 2000-03-04-v0.5.1-1
config.sub 2000-02-03 Thomas Eschenbacher Thomas Eschenbacher [1e7d67] checkin of historic release 2000-02-04-v0.5.0-15
configure.in 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
install-sh 1998-12-12 Martin Wilz Martin Wilz [429088] checkin of historic release 1998-12-13-v0.29-pre2
kwave.kdevprj 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
kwave.lsm 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
kwave.spec.in 2000-04-23 Thomas Eschenbacher Thomas Eschenbacher [45d3b7] checkin of historic release 2000-04-24-v0.5.2
libtool.m4.in 2000-02-03 Thomas Eschenbacher Thomas Eschenbacher [1e7d67] checkin of historic release 2000-02-04-v0.5.0-15
missing 2000-02-03 Thomas Eschenbacher Thomas Eschenbacher [1e7d67] checkin of historic release 2000-02-04-v0.5.0-15
mkinstalldirs 1998-12-12 Martin Wilz Martin Wilz [429088] checkin of historic release 1998-12-13-v0.29-pre2
stamp-h.in 1998-12-12 Martin Wilz Martin Wilz [429088] checkin of historic release 1998-12-13-v0.29-pre2

Read Me

Hi,

This is the kwave source distribution, a simple soundeditor for KDE.

Use kwave with care (save often, and to different files...), since it has not 
left BETA-State yet.

Since I didn't get the Makefiles right yet, it is necessary first to compile
and install the libraries. Then you can compile the binary and the plugins...
Also watch for old versions of the libraries on your system. If you have
them delete them first (libkwave.so/libkwavegui.so)

So step by step starting in the main distribution directory you do this:

./configure 
cd libgui
make 
make install
cd ..
make
make install

Requirements:

This distribution uses the standard template for a kde app, kexample.

Therefore you need autoconf-2.12 and automake-1.2 or higher, not to
mention the KDE-libs-Distribution and then the qt-lib 1.40...

Further requirements are glibc>2.07 for pthreads. Earlier versions of
libpthread (included in glibc) do not work with qt-lib (programm crashes at
start), don't know why, yet...
Not tested are libc5 with linuxthreads, if someone succeeds with this
combination please notify me !
(Note that linuxthreads has requirements for specific libc versions)

Good Luck, and if not, mail me about the bugs...

Martin Wilz