#5 Compile problem with gcc-2.96/3.0

reproducible
closed
compiling (22)
8
2012-09-30
2001-08-01
No

Hi,

it has been pointed out that there is a compile with
some versions of gcc and Qt. The gcc-2.96 compiler of
Mandrake 8 is known to make problems.

To make that clear: I do not want to support that
development version called "gcc-2.96". For details,
see: "http://gcc.gnu.org/gcc-2.96.html"

I use qt-2.3.0-13, kde-2.1.1 and gcc-2.95.3-73 and that
works.

Yesterday I tried to compile gcc-3.0, but this one had
problems with qt-2.3.0: "undefined reference to
`QString::makeSharedNull()" that are said to disappear
in newer qt versions.

Today I will try to update to qt-2.3.1 or higher and
test this with gcc-3.0...

some users wrote me the following:
> [...]
> TopWidget.h:296: class TopWidget::ZoomListPrivate' is private > TopWidget.cpp:120: within this context > make[2]: *** [TopWidget.o] Error 1 > make[2]: Leaving directory/usr/src/redhat/BUILD/kwave-0.6.0/kwave'

Discussion