kscope .configure error

Anonymous
2011-07-19
2012-10-31

  • Anonymous
    2011-07-19

    Hi,
    I am running Red Hat Enterprise Linux AS release 4 (Nahant Update 8). It is an
    x86_64 bit system.
    I have the source code under ~/kscope/ and run configure from there like this:
    ./configure prefix=/users/sri/kscope_1_6_2_bin

    This produces the error:
    checking build system type... x86_64-unknown-linux-gnu
    checking host system type... x86_64-unknown-linux-gnu
    checking target system type... x86_64-unknown-linux-gnu
    checking for a BSD-compatible install...
    /auto/andatcd/coreutils/5.0/bin/install -c
    checking for -p flag to install... yes
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /auto/andatcd/coreutils/5.0/bin/mkdir
    -p
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for kde-config... /usr/bin/kde-config
    kde-config: Unknown option '--libsuffix'.
    kde-config: Use --help to get a list of available command line options.
    checking where to install... /users/svandalu/kscope_1_6_2_bin (as requested)
    checking for style of include used by make... GNU
    checking for gcc... gcc
    checking for C compiler default output file name...
    configure: error: C compiler cannot create executables
    See `config.log' for more details.

    Config.log has this excerpt:

    ----------- ##

    Core tests. ##

    ----------- ##

    configure:2265: checking build system type
    configure:2283: result: x86_64-unknown-linux-gnu
    configure:2305: checking host system type
    configure:2320: result: x86_64-unknown-linux-gnu
    configure:2342: checking target system type
    configure:2357: result: x86_64-unknown-linux-gnu
    configure:2417: checking for a BSD-compatible install
    configure:2485: result: /auto/andatcd/coreutils/5.0/bin/install -c
    configure:2500: checking for -p flag to install
    configure:2513: result: yes
    configure:2524: checking whether build environment is sane
    configure:2567: result: yes
    configure:2582: checking for a thread-safe mkdir -p
    configure:2621: result: /auto/andatcd/coreutils/5.0/bin/mkdir -p
    configure:2634: checking for gawk
    configure:2650: found /auto/andatcd/sibyte_broadcom/6.0/bin/gawk
    configure:2661: result: gawk
    configure:2672: checking whether make sets $(MAKE)
    configure:2694: result: yes
    configure:2972: checking for kde-config
    configure:3034: result: /usr/bin/kde-config
    configure:3058: checking where to install
    configure:3066: result: /users/svandalu/kscope_1_6_2_bin (as requested)
    configure:3117: checking for style of include used by make
    configure:3145: result: GNU
    configure:3292: checking for gcc
    configure:3308: found /auto/andatcd/gcc/2.95.3/bin/gcc
    configure:3319: result: gcc
    configure:3557: checking for C compiler version
    configure:3565: gcc --version >&5
    2.95.3
    configure:3569: $? = 0
    configure:3576: gcc -v >&5
    Reading specs from /auto/andatcd/gcc/2.95.3/lib/gcc-lib/i686-pc-linux-
    gnu/2.95.3/specs
    gcc version 2.95.3 20010315 (release)
    configure:3580: $? = 0
    configure:3587: gcc -V >&5
    gcc: argument to -V' is missing configure:3591: $? = 1 configure:3614: checking for C compiler default output file name configure:3636: gcc conftest.c >&5 /tmp/cc03s6YR.s: Assembler messages: /tmp/cc03s6YR.s:9: Error: suffix or operands invalid forpush'
    /tmp/cc03s6YR.s:16: Error: suffix or operands invalid for `pop'
    configure:3640: $? = 1
    configure:3678: result:
    configure: failed program was:
    | / confdefs.h. /

    Please let me know what I should do to fix this problem.

    Thanks,
    Sri