Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

kplayer and screensaver?

Users
2007-07-15
2013-04-16
  • I am not sure if its a bug or just my fault.
    but with recent cvs kplayer versions the screensaver is not
    deactivated while wachting a movie.
    I have no clue because it works fine with just (g)mplayer.

    kplayer-mplayer-log(yes I replaced file name with *,
    and sorry for this weird german-english-log):

    MPlayer dev-SVN-rUNKNOWN-4.1.2 (C) 2000-2007 MPlayer Team
    CPU: AMD Athlon(tm) 64 Processor 3500+ (Family: 15, Model: 15, Stepping: 0)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
    Kompiliert für x86 CPU mit folgenden Erweiterungen: MMX MMX2 3DNow 3DNowEx SSE SSE2
    Konnte Joystick-Gerätedatei '/dev/input/js0' nicht öffnen: No such file or directory
    Konnte Joystick nicht initialisieren.
    Terminal type `unknown' is not defined.
    Playing ***********************************.
    ID_VIDEO_ID=0
    ID_VID_0_NAME=Japanese
    [mkv] Track-ID 1: video (V_MS/VFW/FOURCC) "Japanese", -vid 0
    ID_AUDIO_ID=0
    ID_AID_0_NAME=Japanese DTS
    ID_AID_0_LANG=jpn
    [mkv] Track-ID 2: audio (A_DTS) "Japanese DTS", -aid 0, -alang jpn
    ID_AUDIO_ID=1
    ID_AID_1_NAME=English
    ID_AID_1_LANG=eng
    [mkv] Track-ID 3: audio (A_VORBIS) "English", -aid 1, -alang eng
    ID_SUBTITLE_ID=0
    ID_SID_0_NAME=English
    ID_SID_0_LANG=eng
    [mkv] Track-ID 4: subtitles (S_TEXT/ASS) "English", -sid 0, -slang eng
    [mkv] Werde Video-Track 1 abspielen.
    [mkv] Werde Untertitel-Track 4 anzeigen.
    Matroska-Dateiformat erkannt!
    VIDEO:  [H264]  704x396  12bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
    ID_FILENAME=******************************
    ID_DEMUXER=mkv
    ID_VIDEO_FORMAT=H264
    ID_VIDEO_BITRATE=0
    ID_VIDEO_WIDTH=704
    ID_VIDEO_HEIGHT=396
    ID_VIDEO_FPS=23.976
    ID_VIDEO_ASPECT=1.7778
    ID_AUDIO_FORMAT=8193
    ID_AUDIO_BITRATE=0
    ID_AUDIO_RATE=48000
    ID_AUDIO_NCH=6
    ID_LENGTH=6925.68
    ==========================================================================
    Öffne Videodecoder: [ffmpeg] FFmpeg's libavcodec codec family
    Ausgewählter Videocodec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
    ==========================================================================
    ID_VIDEO_CODEC=ffh264
    ==========================================================================
    Öffne Audiodecoder: [ffmpeg] FFmpeg/libavcodec audio decoders
    AUDIO: 48000 Hz, 6 ch, s16le, 768.0 kbit/16.67% (ratio: 96000->576000)
    ID_AUDIO_BITRATE=768000
    ID_AUDIO_RATE=48000
    ID_AUDIO_NCH=6
    Ausgewählter Audiocodec: [ffdca] afm: ffmpeg (FFmpeg DTS)
    ==========================================================================
    AO: [alsa] 48000Hz 6ch s16le (2 bytes per sample)
    ID_AUDIO_CODEC=ffdca
    Starte Wiedergabe...
    VDec: VO wird versucht, auf 704 x 396 (Bevorzugter Farbraum: Planar YV12) zu setzen.
    VDec: Verwende Planar YV12 als Ausgabefarbraum (Nummer 0).
    Film-Aspekt ist 1.78:1 - Vorskalierung zur Korrektur der Seitenverhältnisse.
    ID_VIDEO_ASPECT=1.7778
    VO: [xv] 704x396 => 704x396 Planar YV12  [zoom]
    X11 error: BadAccess during XSelectInput Call
    X11 error: The 'ButtonPressMask' mask of specified window has probably already used by another appication (see man XSelectInput)
    X11 error: MPlayer discards mouse control (reconfiguring)

    I would be happy if ou could give me a hint :)

     
    • kiriuja
      kiriuja
      2007-07-15

      I don't think I changed anything related to screen saver disabling for quite a while...

      Do you know what kind of screen saver it is exactly? KDE? Gnome? X?

       
    • KDE screensaver, a simple black screen.

      But it downgraded to kplayer 0.6.2 and everything works fine.
      After that I upgrade to the last cvs version and it worked fine too.
      I think I was going nuts, but after I opened the kplayer settings and
      clicked tghe apply button(without changing anything), the screensaver
      starts again in the movie. Were there some config changes?

      If possible I dont want to reset my config, even through it is not that
      mutch.

       
      • kiriuja
        kiriuja
        2007-07-17

        Well, I've done exactly as you say several times, using the KDE black screen screensaver, and KPlayer still disabled the screensaver whenever a video was playing and enabled it back when it stopped playing.

        So there must be something else going on...

        In KPlayer 0.6.x there is no configuration option that affects screen saver disabling.

         
    • Ok, it is not the screensaver(I turnt it off), it is the powersaving mode.
      The display turns black after 10mins and goes standby (as I configured it in kde).
      But why?

       
      • kiriuja
        kiriuja
        2007-07-17

        OK, good, it makes more sense now. :)

        Please do me a favor. Open Settings/Configure KPlayer, go to the
        Advanced section and put

        -stop-xscreensaver

        into the Additional command line arguments field and see if that
        makes a difference.

        And please don't forget to let me know what you get.

        Thanks!

        --
        kiriuja

         
        • hm.. looks like it helps.
          I dont know why, because -stop-xscreensaver doesnt sound like the dpms stuff.
          Anyway I hope it is just a tmp fix, isnt it?

           
          • kiriuja
            kiriuja
            2007-07-17

            Yes it is temporary, I am going to always include that option on the
            MPlayer command line and also remove the screen saver from KPlayer since MPlayer does KDE screen saver disabling as well.

            I'll let you know once I commit the change. Thanks for letting me know about the problem.

             
            • Ahh bad news, it didnt help!
              -stop-xscreensaver is appended but it didnt help.
              Maybe the mouse was moving or something like that before I didnt see.
              Sorry :/

              But I get the feeling that something strange is going on, between kde settings and originaly xorg.conf, like xorg-server has its default powersaving timeout.

              I changed the standby to 2minutes(in kde), nothing happened within this time, but after 10min it went to standby.
              As I have no clue... I'll just go to bed for now.

               
              • kiriuja
                kiriuja
                2007-07-18

                I have also seen strange behavior with DPMS, it really doesn't work at all more than once per X session. So I have no way of testing it reliably.

                But -stop-xscreensaver is supposed to turn DPMS off as well. So I will make a change to always pass that option to MPlayer, but will keep KPlayer's own code for disabling KDE screensaver. This is mostly because MPlayer may not turn things back on if it crashes for example, which still happens too often.

                You can try running MPlayer with the -stop-xscreensaver option, and if it doesn't work, post about it on the mplayer-users mailing list.

                 
                • kiriuja
                  kiriuja
                  2007-07-20

                  I have committed the change that adds -stop-xscreensaver to the
                  MPlayer command line.

                  If you still get problems with DPMS, try asking on the mplayer-users
                  mailing list or on #mplayer on FreeNode.

                   
                  • After recompiling all X-related stuff everything works fine.
                    It was probably just a local bad/weird linking problem.