Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#46 Double entries for keyboard shortcuts

open
nobody
None
5
2007-03-29
2007-03-29
lodp
No

I noticed that in the menu Settings > Configure Shortcuts, for many items there are 2 identical lines, only one of which actually assigns a shortcut.

I've got two lines for the following actions:

Collection
Decrease Delay
Files
Forward
Increase Delay
Move Down
Move Up
New Playlist
Play
Playlists
Properties
Select all
URL

All those actions have double entries, but only one of the entries actually controls the short cut. Changing the other one, respectively, doesn't do anything.

I'm using Kplayer 0.6.1 and Kubuntu Edgy with KDE 3.5.6.

Discussion

  • kiriuja
    kiriuja
    2007-03-29

    Logged In: YES
    user_id=137121
    Originator: NO

    You are right, but some of them are not just duplicate entries. They are different actions with the same name. Like for example there's Audio/Increase Delay and Subtitles/Increase Delay. Other entries can be made into one though, so I'll think about how to do that.

     
  • lodp
    lodp
    2007-04-03

    Logged In: YES
    user_id=1356011
    Originator: YES

    Do you think one could rename the entries that are in fact not duplicates? Thanks for your work, man!

     
  • kiriuja
    kiriuja
    2007-04-15

    Logged In: YES
    user_id=137121
    Originator: NO

    In some cases it would be difficult to come up with names that are not duplicates. For example File/Properties... opens properties for the currently loaded files, and Library/Properties... opens properties for the current item in the multimedia library. So they both show up as Properties... in the toolbar config dialog. From looking at the kdelibs code, the only way to distinguish the two items is by the action description that is displayed at the bottom of the dialog when you select an item. I wish there was a way to give them different names just in that dialog, but for now there isn't any.

     
  • lodp
    lodp
    2008-12-16

    I just looked at the "Configure Shortcuts.." Dialogue again, and while it seems from a cursory glance there's less duplicates now, there's still 2x "Increase Delay" and 2x "Decrease Delay. One controls the subtitles and the other the audio.

    I'm not sure if I understand your last post correctly, but if it's in your power to name these, can't you just name them Decrease Subtitle Delay / Decrease Audio Delay?