#13 Crash by clicking on compiling failures

v0.8.0alpha
closed-works-for-me
None
5
2007-06-17
2007-05-28
Thomas Grübler
No

I loaded my big Robotchallenge project. 6 source files + 6 headers. about 13kb with -Os. I now wanted to debug. so i switched from atmega32 to at85... (cadmaniac knows). and then i compiled. many failures ocured (there should be none and no warnings!). about ADC.. not defined. i wanted to click on a failure. and then kontrollerlab crashed. this is the debugging output.

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1234753840 (LWP 22231)]
[KCrash handler]
#5 0x0806acf9 in ?? ()
#6 0x084ee178 in ?? ()
#7 0xb7f84cd0 in ?? () from /lib/ld-linux.so.2
#8 0x08060c66 in ?? ()
#9 0x00000003 in ?? ()
#10 0x0000001b in ?? ()
#11 0x0000000a in ?? ()
#12 0x00000000 in ?? ()

Discussion

  • Logged In: YES
    user_id=902327
    Originator: NO

    This bug could not be reproduced. It actually works for me. Can You please send the files or check if this bug is already fixed with the most recent SVN version?

    If the bug remains, please compile KontrollerLab with debugging turned on, using
    ./configure --enable-debug=full

    thanks!

     
    • assigned_to: nobody --> cadmaniac
    • status: open --> pending-works-for-me
     
    • status: pending-works-for-me --> closed-works-for-me
     
  • Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).