#702 Japanese input not working

open
nobody
General (85)
5
2011-08-10
2011-08-03
yukinoroh
No

Ubuntu 11.04/64bit
Kompozer 0.8b3 (20100228)
Imput methods "scim", "scim-bridge", "scim-immodule", none allow me to input Japanese in Kompozer.
So far only Kompozer behaves that way.

Discussion

  • yukinoroh
    yukinoroh
    2011-08-03

    Tested with IBUS (the default imput method) as well, no result.

     
  • yukinoroh
    yukinoroh
    2011-08-03

    • priority: 5 --> 7
     
  • yukinoroh
    yukinoroh
    2011-08-10

    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: 間違った ELF クラスです: ELFCLASS64

    (kompozer-bin:2204): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: 間違った ELF クラスです: ELFCLASS64

    (kompozer-bin:2204): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: 間違った ELF クラスです: ELFCLASS64

    (kompozer-bin:2204): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

    /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: 間違った ELF クラスです: ELFCLASS64

    (kompozer-bin:2204): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so

    (kompozer-bin:2204): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-scim.so: 間違った ELF クラスです: ELFCLASS64

    (kompozer-bin:2204): Gtk-WARNING **: Loading IM context type 'scim' failed

    (kompozer-bin:2204): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-scim.so: 間違った ELF クラスです: ELFCLASS64

    (kompozer-bin:2204): Gtk-WARNING **: Loading IM context type 'scim' failed

    (kompozer-bin:2204): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-scim.so: 間違った ELF クラスです: ELFCLASS64

    (kompozer-bin:2204): Gtk-WARNING **: Loading IM context type 'scim' failed

    (kompozer-bin:2204): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-scim.so: 間違った ELF クラスです: ELFCLASS64

    (kompozer-bin:2204): Gtk-WARNING **: Loading IM context type 'scim' failed

     
  • yukinoroh
    yukinoroh
    2011-08-10

    I just pasted the command line output, it looks like it's due

    After trying the build provided with Ubuntu (which doesn't include the fix for the line break bug #1831943 and #1607834), I noticed that it does work there. So my bet is it's related to ia32. But I have the compatibility libraries installed, shouldn't a 32bit binary run perfectly anyway?

     
  • yukinoroh
    yukinoroh
    2011-08-10

    • summary: Japanese input broken --> Japanese input not working
     
  • yukinoroh
    yukinoroh
    2011-08-10

    temporary solution: provide a 64bit build...

     
  • yukinoroh
    yukinoroh
    2011-08-10

    • priority: 7 --> 5