Problems with KOL-CE install

Help
rseiden
2007-11-06
2013-04-23
  • rseiden
    rseiden
    2007-11-06

    I had some problems installing KOL-CE, so I ended up uninstalling Lazarus completely, and reinstalling it from scratch. I installed Lazarus 0.9.23 with FPC 2.2.1, and then the arm-wince FPC 2.2.1 part, then KOL-CE 2.80 all together. I followed the direction at http://wiki.freepascal.org/KOL-CE on creating a project. I added a button to the form after I opened the new lpi file, and double clicked on the button to add a Click event to it.

    I got an error screen:

    The component editor of class "TKOLObjectCompEditor"has created the error:
    "Unable to find method. Plz fix the error shown in the message window."

    The messagew window said:

    unit1.pas (9,37) Error: unit not found: Classes

    Lines 8, 9 and 10 of unit1.pas is:

    uses Windows, Messages, KOL {place your units here->}
    {$IFDEF LAZIDE_MCK}, Forms, mirror, Classes, Controls, mckCtrls, mckObjs, Graphics;
    {$ELSE} ; {$ENDIF}

    It's important to note that between the arm install and KOL-CE install, I'm able to compile an arm based project (http://www.adrive.com/public/65420b560b5c39169e76325412db4b7a07cb4630a8056317de7668b5803c7846.html). The issue only occurs AFTER I run the install process for KOL-CE.

    Has anyone run into this before? Any idea why this is happening to me?

    Thanks
    Rick Seiden

     
    • rseiden
      rseiden
      2007-11-06

      OK.  I tried it one more time, and this time, for some reason, it worked.

      I have other issues, but I have to "RTFM" before I post them.