Problems installing Kile

  • AAL

    Hi there,

    I'm writing this message because I'm unable to install kile.

    I'm running OpenBSD and my problems began almost from the beginning of the installation process, running ./configure. I succeeded (or at least, think I did) in this stage setting MOC and UIC_PATH environment variables to the apropriate executables, and running:

     ./configure --prefix=/usr/local --with-qt-dir=/usr/local/lib/qt3 --with-qt-includes=/usr/local/include/X11/qt3 --with-qt-libraries=/usr/local/lib

    When this finished, I got the message:

    Good - your configure finished. Start make now.

    So I tried to run precisely that: make. But when this process is going on, I always get the following errors:
    userhelp.cpp:32: kileconfig.h: No such file or directory
    *** Error code 1

    Stop in /home/infaal01/descargas/Kile-1.8b2/src/kile.
    *** Error code 1

    Stop in /home/infaal01/descargas/Kile-1.8b2/src/kile (line 740 of Makefile).
    *** Error code 1

    Stop in /home/infaal01/descargas/Kile-1.8b2/src (line 473 of Makefile).
    *** Error code 1

    Stop in /home/infaal01/descargas/Kile-1.8b2 (line 443 of Makefile).
    *** Error code 1

    Stop in /home/infaal01/descargas/Kile-1.8b2 (line 338 of Makefile).

    Which seem to be true, as there's no file in my whole system called "kileconfig.h". I've found out that if I try creating a dummy file named that way, when I run "make clean", it gets deleted, so I'm beginning to think this file should be generated by the "configure" script and that something's going wrong with it.

    Please help this newbie get his kile setup done.

    PS: Neither version 1.7.1 nor 1.8b2 would work and they fail at exactly the same point. Thanks in advance.

    • magicpirx

      'kileconfig.h' and some other files are created by the kconfig_compiler, which is part of the 'KConfig XT' framework.

      This means that you need KDE 3.2.x or better.