failed running kiax.. :(

Help
ian_
2005-06-01
2013-04-25
  • ian_
    ian_
    2005-06-01

    failed running kiax.. what's wrong...hope somebody can help me here is the error...

    ian@ubuntu:~$ kiax
    Qt: Locales not supported on X server
    Wed Jun 1 21:49:45 2005 Using IAXClient ver. CVS-2005/06/01-20:21
    Wed Jun 1 21:49:45 2005 IaxWrapper::iaxc_initialize() result = -1
    Error message:cannot initialize iaxclient!

    Exitting application. Possible reason: Device initialization failed.

     
    • Emo
      Emo
      2005-06-02

      Hi,

      what it looks like is that Kiax is unable to perform sound-device initialization. If you have other programms that are running and are using the sound device this can happen. Also it can happen if any of your sound deamons are active This can happen when you have sound theme and you execute kiax before the daemon has finished playing the sound events.Try to stop artsd or esd if one of them is running.

      Greetings,
      Emil

       
    • krusty.ar
      krusty.ar
      2005-12-27

      I have this same error after closing artds (I don't use esd) and every other audio app that I could find. Where else should I look?

      Thanks. Lucas.

       
    • krusty.ar
      krusty.ar
      2005-12-27

      I forgot to mention that I'm running gentoo with kernel 2.6.8 and kde-3.5

       
    • Emo
      Emo
      2006-01-01

      OK, one possible reason is turned off ALSA-OSS compatibility. Kiax/iaxclient uses OSS. Please check your kernel if OSS is enabled.

       
      • krusty.ar
        krusty.ar
        2006-01-02

        It was OSS (I didn't have it in the kernel), sorry I didn't post, I forgot that I had asked here.