Kiax & user account - launching failure

Help
attar
2005-04-17
2013-04-25
  • attar
    attar
    2005-04-17

    Hallo
    I've just installed Kiax on my suse 9.2, created new account, gave all the data needed and came across the problem with registration. Console gives this infirmation:

    nie kwi 17 14:08:03 2005 Using IAXClient ver. CVS-2005/04/15-18:42
    nie kwi 17 14:08:04 2005 IaxWrapper::iaxc_initialize() result = 0
    nie kwi 17 14:08:10 2005 IaxWrapper::start_iax_client() starting processing thread..
    nie kwi 17 14:08:10 2005 IaxWrapper::iaxc_start_processing_thread() result = 0
    nie kwi 17 14:08:10 2005 IaxWrapper::registerMultipleAccounts() registering accounts..
    nie kwi 17 14:08:10 2005 IaxWrapper::registerMultipleAccounts() register Tlen [ "here_my_login":xxx@centrala.tlenofon.pl]
    nie kwi 17 14:08:13 2005 IaxWrapper::event_text() Message: Type=1 Message=Registration rejected

    when running root console it displays:

    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    kiax: cannot connect to X server :0.0

    However, when I logged out, logged in as a root and launched Kiax, everything was working PERFECTLY!
    Could anyone help mi with making Kiax work on user account? I don't want to logg in as a root all the time!
    Thanx in advance

     
    • growchie
      growchie
      2005-04-18

      So. First try to make sure that you have entered your credentials correctly. Then make sure that you are using kiax-0.8.4-2.SUSE9.2.rpm. You shold have no problems.

       
    • Emo
      Emo
      2005-04-18

      Now.. if it has worked with root then there should be no reason this not to work with a regular user.
      Please go to $HOME/.qt and there you will see a file named kiaxrc

      There are all the settings. Please check if the server address, username and password are the same as they should be. Be aware that the server field is not controlled also any empty spaces may cause problems.

      Emil

       
    • polrus
      polrus
      2005-04-19

      IMHO it's something with persmisions to connect to X server and it has nothing to do with kiax.

      for example in my linux only 1 user is allowed to be connected to the X-server
      so let's say you're logged as Regular_User, and you are in kde or something. now you want to run a GUI program for example kiax but as root. so i You execute su and try to run kiax but then You get

      Xlib: connection to ":0.0" refused by server
      Xlib: No protocol specified

      and it means u have to do this :

      cp /home/Regilar_User/.Xauthority /root

      it has nothing to do wiht kiax