New Mac OSX beta bombs on me

Help
2008-06-29
2013-04-25
  • I'm so happy there is a beta for Mac now. Please help me get it working. Right now, it bombs. I'm running Lepoard 10.5.3.

    admin$ /Applications/Kiax.app/Contents/MacOS/Kiax 
    Kiax -INFO- Service Naming started successfully.
    Kiax -INFO- Service Storage started successfully.
    Kiax -INFO- Module CDRModuleImpl initialized.
    Kiax -INFO- Module ContactsModuleImpl initialized.
    Kiax -INFO- Module AccountsModuleImpl initialized.
    Kiax -INFO- Module SignalingModuleIAX2 initialized.
    Kiax -INFO- Module ConfigurationModuleImpl initialized.
    QObject::moveToThread: Current thread (0x143f8d0) is not the object's thread (0x1409ca0).
    Cannot move to target thread (0x1409ca0)

    On Mac OS X, you might be loading two sets of Qt binaries into the same process. Check that all plugins are compiled against the right Qt binaries. Export DYLD_PRINT_LIBRARIES=1 and check that only one set of binaries are being loaded.
    QObject::moveToThread: Current thread (0x143f8d0) is not the object's thread (0x1409ca0).
    Cannot move to target thread (0x1409ca0)

    On Mac OS X, you might be loading two sets of Qt binaries into the same process. Check that all plugins are compiled against the right Qt binaries. Export DYLD_PRINT_LIBRARIES=1 and check that only one set of binaries are being loaded.
    QObject::moveToThread: Current thread (0x143f8d0) is not the object's thread (0x1409ca0).
    Cannot move to target thread (0x1409ca0)

    On Mac OS X, you might be loading two sets of Qt binaries into the same process. Check that all plugins are compiled against the right Qt binaries. Export DYLD_PRINT_LIBRARIES=1 and check that only one set of binaries are being loaded.
    QObject::moveToThread: Current thread (0x143f8d0) is not the object's thread (0x1409ca0).
    Cannot move to target thread (0x1409ca0)

    Sun Jun 29 06:57:55 admins-power-mac-g4.local Kiax[47757] <Error>: CGImageCreate: invalid image size: 0 x 0.
    QObject::moveToThread: Current thread (0x143b1b0) is not the object's thread (0x1409e10).
    Cannot move to target thread (0x1409e10)

    etc.....

    Maybe this is a result of my having installed the Open Source version of the Qt libraries? (which I also have not been able to work properly), but actually I don't think so. I'd appreciate help in walking me through. Thanks,
    Yitzhak

     
    • Emo
      Emo
      2008-06-29

      Does the GUI come at the end? Or does it crash? If yes, would you please post the complete log? Thanks!

      Cheers,
      Emil

       
      • Thank you very much for the response. I posted everything I have. There is no GUI at all. I'll be glad to post any additional information. Just tell me specifically what.

         
    • I'm available on Skype or chat if necessary. Let me know

       
      • Emo
        Emo
        2008-06-30

        When you installed Qt4 on your mac, have you been able to execute some of the example applications that came with it (/Developer/Examples/Qt)?

        I will try to reach you on skype, thanks!

        Regards,
        Emil

         
        • Yes. The examples all work. There is one problem however, it seems that the path is incorrect. I can run the examples only when I explicitly give the full path of the top program. I don't know if that is related, but perhaps you can help me.
          Thank you