Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

kiax2b2 bug.

Help
2008-07-02
2013-04-25
  • There is a bug in kiax2b2.

    The scenario is Kiax2b2-caller -> Asterisk 1.2.29 -> Kiax2b2-receiver
    Both kiax2b2 running on Ubuntu Hardy 8.04.

    Kiax2b2 places a call, the Kiax2b2-receiver rings, so I click Answer button.
    Now there is no audio between caller and receiver.

    Communication starts if on Kiax2b2-receiver, I click on "Kiax" window and then back on "Call" window. Now I can talk with caller with no problem.
    This problem occurs expecially if it is the first call between caller and receiver, in other words if caller and receiver have just launched kiax.

    Thanks a lot.
    Valerio

     
    • Emo
      Emo
      2008-07-03

      Hi Valerio,

      I can't reproduce the problem.. do you test on two machines or only on one?
      I am also testing with Ubuntu hard 8.04..

      Greetings,
      Emil

       
      • Hi Emil,
        I made my tests on two different machines (both Ubuntu 8.04 fresh installations with upgrades).

        Here the receiver debug log (only the section about new coming call, answer, switch windows and hang up, I added some silly comments (...)  ).
        ...
        Kiax -DEBUG-  ACTIVE_INCOMING_RINGING: 300
        Kiax -INFO- Incoming call. Call number 0
        Kiax -DEBUG- getContacts(300) IN
        Kiax -DEBUG- find query = select rowid from Contact where extension like '%300%' OR contactName like '%300%'
        Kiax -DEBUG- getContacts(300) OUT
        Kiax -DEBUG- WINDOW STATE CHANGE = 33
        Kiax -INFO- Ringing. Call number 0
        Kiax -DEBUG- event callback exits 1
        Kiax -DEBUG- event callback exits 2
        Kiax -DEBUG- WINDOW STATE CHANGE = 99
        Kiax -DEBUG-  ACTIVE_CALL_ESTABLISHED: 300
        Kiax -INFO- Active call changed. New active number 0
        Kiax -INFO- Call complete (established). Call number 0
        Kiax -DEBUG- event callback exits 2  (... no audio...)
        Kiax -WARNING- Received unknown event. Leaving it not handled.  (... ?????????)
        Kiax -DEBUG- WINDOW STATE CHANGE = 99  (Now I switched to Kiax window)
        Kiax -DEBUG- WINDOW STATE CHANGE = 99   (... and back to Call window)
        Kiax -DEBUG- SET ACTIVE CALL = 0
        Kiax -DEBUG-  ACTIVE_CALL_ESTABLISHED: 300
        Kiax -INFO- Active call changed. New active number 0
        Kiax -INFO- Call complete (established). Call number 0
        Kiax -DEBUG- event callback exits 2  (... here we go, I can listen and talk!)
        warning: The VAD has been replaced by a hack pending a complete rewrite
        Kiax -INFO- Call became inactive. Call number 0  (... the caller is hanging up) 
        Kiax -DEBUG- ListWidgetItem - call state answered call direction in
        Kiax -DEBUG- event callback exits 2
        Kiax -DEBUG- WINDOW STATE CHANGE = 99
        Kiax -DEBUG- getParameters(StateAuto) IN
        Kiax -DEBUG- ConfigurationParameter DESTRUCT IN
        ...

        It seems that the "Kiax -WARNING- Received unknown event. Leaving it not handled." can be linked to the problem.
        I know debug an unreproducible bug it a tedious job, anyway I can make more tests.

        Thanks
        Valerio