Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Setting up SCP connection

Help
Anonymous
2010-05-30
2012-10-07

  • Anonymous
    2010-05-30

    KeePass version: 2.10
    KeePassSync version: 2.0.10.1

    Hi,

    I am sorry, but based on the info available, I did not manage to set up
    synchronisation with my own file server (which I can access through SCP
    otherwise). There is one thing I don't understand, however. I already have a
    password database (one .kdbx file), that I copied to a given directory of the
    server. Why does the UI only ask me for a directory, not the actual database
    file???

    Here is the output when I just enter the directory the .kdbx file is in (from
    ticking Debug mode - another comment here is that the terminal window closes
    immediately after it fails, so I had to do fast screen captures, then system
    pauses to avoid that... :-)))) Not the best method for debugging):

    Looking up host "192.168.1.17"
    Connecting to 192.168.1.17 port 22
    Server version: SSH-1.99-OpenSSH_3.9p1
    We claim version: SSH-2.0-PuTTY_Release_0.60
    Using SSH protocol version 2
    Doing Diffie-Hellman group exchange
    Doing Diffie-Hellman key exchange with hash SHA-1
    Host key fingerprint is:
    ssh-rsa 1024 ******
    Initialised AES-256 SDCTR client->server encryption
    Initialised HMAC-SHA1 client->server MAC algorithm
    Initialised AES-256 SDCTR server->client encryption
    Initialised HMAC-SHA1 server->client MAC algorithm
    Using username "USER".
    Keyboard-interactive authentication refused
    Sent password
    Access granted
    Opened channel for session
    Started a shell/command
    Using SFTP
    Connected to 192.168.1.17

    Sending file tmp51.tmp, size=30638

    Why do I get "Keyboard-interactive authentication refused"? And what is this
    "tmp51.tmp" file?

    Thanks,
    Janos

     

  • Anonymous
    2010-05-30

    After a few more trials, I have the following:

    • if I enter "~/dir1/dir2/database.kdbx" in the directory field of the "entry generator", then it looks for a filename with the prefix "Keepass-", and in addition inside the indicated directory, hence:
      ~/dir1/dir2/database.kdbx/Keepass-database.kdbx

    output on the first trial:
    unable to identify ~/dir1/dir2/database.kdbx/Keepass-
    database.kdbx/KeePassSyncDir.txt: no such file or directory
    after this, it created this .txt file inside the directory (hence the
    authentication works - otherwise that file could not have been created). On
    the next try:

    unable to identify ~/dir1/dir2database.kdbx/Keepass-database.kdbx: no such
    file or directory

    • even though the file was there. So I'll stop here, without knowing the exact syntax, I am just wasting my time. I could look for the source files and reverse-engineer, but as I am not that good with C code, I would avoid doing that, if possible.

    Thx in advance,
    Janos

     
  • Mitch Capper
    Mitch Capper
    2010-06-01

    Thanks for the detailed report I will take a look to see if we can figure out
    whats going on, just to note its not C its actually c# which is far easier to
    work with and understand, you may want to take a look as you might be
    surprised at what you can understand:).

    In short just on the naming path, it takes the directory you specify if it
    doesn't end in a slash it adds one, then for the file name it is prefixed with
    Keepass- and then the existing db name. So if you have MyPasswords.kbdx its
    Keepass-MyPasswords.kbdx

    Try not using relative paths and Do not include the filename in the path, also
    ensure the directory exists. If you do want to look at the code its
    KeePassSync\Providers\SFTP\main.cs

     
  • loomax
    loomax
    2010-07-07

    Can you logon o your server via WinSCP ?

    First of all i think the message says that logon by typing the password is not
    enabled but only with a public private key pair

    You logon using username "USER" -- is this correct ?

     

  • Anonymous
    2010-10-18

    Hi,

    sorry for disappearing. I did not actually realise I got a reply. Strange. And
    I even got two! Things look much better now. I should have just waited a bit,
    in fact, it establishes 3-4 connections and afterwards, it all works alright.
    I have now set it up and it works fine via SCP, but for one thing:
    when indicating the path for plink/pscp, the "KeePass Root" button does not
    work (I get: "Unable to find pscp/plink.exe at the path specified please
    check") for some reason, even though pscp.exe, plink.exe and the plugin file
    are all located there. However, if I indicate the path in absolute terms, it
    works.
    This is kind of a problem, as I intend to use KeePass from a USB key, which
    might get different drive letters every time it gets put into a different PC.
    Any ideas? I won't rely on an email alert (though that would be best, to
    janos.marki@gmail.com) this time and will check back once a day for a week or
    so... ;-)

    Thx,
    Janos

     
  • Henning Eiben
    Henning Eiben
    2011-02-10

    I noticed the same problem. But looking at procmon where keepass is actually
    searching for plink reveals, that the root folder is not the folder where the
    keepass.exe is, but instead it's some plugin-cache folder. Because of the
    random directory name I assume it's generated at runtime, thus this is not a
    good place to put the plink.exe.

    This is especially bad, because I have keepass on two different machines with
    different folder-structures and thus it would not be easy to have the same
    location for plink on both machines.

     

  • Anonymous
    2012-02-15

    So could this problem (with pscp/plink path) solved for non-absolute paths? It
    is the only way for me for online sync (because of some troubles with built-in
    synchronization), but I am using portable KeePass and absolute paths is not a
    suitable solution in this case.