With the next version of KeePass we will be releasing this plugin in PLGX form
rather than DLL. It will work with any KP version > 2.09 then and allow for
easier upgrading in the future. It does mean we will no longer be distributing
separate DLL's for each of the providers but as long as your 3rd party dll's
start with KeePassSync_* they will still work and be loaded.