Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

'CSplitterWnd' Fehler

2007-02-15
2013-04-22
  • hallo , ich hoffe ich bin bei ihnen richtig gelandet. es geht um keepass für ppc wm5.
    ich habe mir den source reingeladen und versuche es zu kompilieren und zu starten ( es ist eine neue version vom visual studio team suite)
    bekomme aber andauernd folgende fehler.

    Fehler 1 error C2079: 'CMainFrame::m_wndSplitter' uses undefined class 'CSplitterWnd' g:\vbnet-projekte\keepass\keepassppc\MainFrm.h 61
    Fehler 2 error C2079: 'CMainFrame::m_wndSplitter' uses undefined class 'CSplitterWnd' g:\vbnet-projekte\keepass\keepassppc\MainFrm.h 61
    Fehler 3 error C2079: 'CMainFrame::m_wndSplitter' uses undefined class 'CSplitterWnd' g:\vbnet-projekte\keepass\keepassppc\MainFrm.h 61
    Fehler 4 error C2228: left of '.GetRowInfo' must have class/struct/union g:\vbnet-projekte\KeePass\KeePassPPC\MainFrm.cpp 138
    Fehler 5 error C2228: left of '.CreateStatic' must have class/struct/union g:\vbnet-projekte\KeePass\KeePassPPC\MainFrm.cpp 162
    Fehler 6 error C2228: left of '.CreateView' must have class/struct/union g:\vbnet-projekte\KeePass\KeePassPPC\MainFrm.cpp 168
    Fehler 7 error C2228: left of '.CreateView' must have class/struct/union g:\vbnet-projekte\KeePass\KeePassPPC\MainFrm.cpp 174
    Fehler 8 error C2228: left of '.SetRowInfo' must have class/struct/union g:\vbnet-projekte\KeePass\KeePassPPC\MainFrm.cpp 180
    Fehler 9 error C2228: left of '.GetPane' must have class/struct/union g:\vbnet-projekte\KeePass\KeePassPPC\MainFrm.cpp 198
    Fehler 10 error C2228: left of '.GetPane' must have class/struct/union g:\vbnet-projekte\KeePass\KeePassPPC\MainFrm.cpp 199
    Fehler 11 error C2079: 'CMainFrame::m_wndSplitter' uses undefined class 'CSplitterWnd' g:\vbnet-projekte\keepass\keepassppc\MainFrm.h 61

    er findet wohl irgendwie 'CSplitterWnd'  nicht ?!?!?
    das komische ist, wenn ich es bei einem kollegen auf seinem rechner kompiliere geht es problemlos und geht auch zu starten.
    was kann das sein ?
    mfg andreas

     
    • Tobias
      Tobias
      2007-02-15

      Hallo Andreas!

      Wie schon per E-Mail gesagt sollte das Installieren vom Service Pack 1 helfen.
      Steht übrigens auch in der "HowToBuild.txt" drin, wenn ich mich recht entsinne.

      Gruß,
      Tobias