#179 Bad package for Keepass 2.20.1 on Mac OS

KeePass_2.x
open
nobody
None
8
2013-03-15
2012-12-26
Ralph van Cauter
No

Downloaded the Keepass2.20.1 for iMac from http://keepass2.openix.be/
The package contents contains a zero byte large application

1 Attachments

Discussion

<< < 1 2 (Page 2 of 2)
  • Hi,
    I can confirm, that this works! You just need the 'read' permission.
    Do you have also a permission for 'fetching ... - read/write' ? I deleted them after adding the permission for my user.

     
  • Xianthe Xian
    Xianthe Xian
    2013-01-14

    I can confirm this does not work. [http://i.imgur.com/kn714.png] Here is the image of the file info. Note it is still zero bytes and the permissions are fixed. I'm on 10.8.2 and the md5 check was good for my download.

     
    Last edit: Xianthe Xian 2013-01-14
    • clive
      clive
      2013-02-10

      Changing the permissions by adding myself in did not work for me either. The file is still zero bytes and program still crashes after loading. I'm on 10.7.5 plus the md5 check was good for my download.

      Anything else to try to get this app. to work?

       
  • dbagooner
    dbagooner
    2013-01-15

    I don't know if there is a huge difference yet as I've just started setting up KeePass on my devices but after spending hours on this same issue I found the v0.4.3 package at http://www.keepassx.org works on the Mac and syncs properly to the windows KeePass (www.keepass.info) as well as the android KeePassDroid.

    Can anyone tell me if this is bad to use or post about as a temp workaround before I use it on my passwords?

     
  • Paul
    Paul
    2013-01-16

    KeePassX is read only for V2 databases, apart from that it's fine.

    cheers, Paul

     
  • Arnab Sen
    Arnab Sen
    2013-01-16

    I had the same problem. On looking at the permissions for Keepass (right-click >-> get info -> Sharing and Permission), it showed entries for admin and the >"everyone" group. I created a new entry for my own logon and it works just fine.
    Seems that "everyone" may not really mean everyone (or I'm not in everyone) :)

    I can confirm this works for Mac OS X 10.7.5

     
  • Joseph Celona
    Joseph Celona
    2013-01-16

    I've reviewed the information in this support thread, and I have these problems, both the file size and permissions issue, both I was able to fix. However I am having another problem that may be related to Gatekeeper, but I'm not sure. When I run KeePass on my Mac (OS X 10.8.2), the application seems to start, appears in my Doc, but then simply disappears after a few seconds, no error message or warning, just seems to start, then exits.

    Digging through my console messages, I see this:

    1/15/13 3:32:25.044 PM com.apple.launchd.peruser.502[148]: ([0x0-0x5e05e].KeePass2.20.1[495]) Exited with code: 1

    And best I can tell, error code 1 means everything is just fine. Can anyone explain this behavior and a fix to get the application to open normally and not exit?

    Thanks, -Joe

     
  • Xianthe Xian
    Xianthe Xian
    2013-01-16

    Joe - that is the exact problem I am having now, and why I'm saying it is not fixed. Yes permissions are fixed, though the size is not, I have the exact error code problem you describe and the application disappears in the dock.

    I see that we are both running 10.8.2.

     
  • Dave Barreto
    Dave Barreto
    2013-01-17

    Hi guys, same issue here, OS X 10.8.2; after sorting out the permissions issues as outlined previously in the thread by explicitly adding my user to the permissions on the app package, the software dies about 1 second after launching same as yours.

    I then tried the official portable version (zip), and that one died too:

    Unhandled Exception:
    System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.ThemeEngine ---> System.ArgumentException: The requested FontFamily could not be found [GDI+ status: FontFamilyNotFound]

    Digging around with that error message and the problem was that I didn't have X11 installed. I downloaded that here:

    http://xquartz.macosforge.org/landing/

    That resolved the error for me; for both the portable and the OS X package. I'm up and running; hope that gets you guys up and running too.

     
    • H-phys
      H-phys
      2013-01-17

      You are a hero and a saint. I had the permissions all sorted out, but I was getting that taunting icon-bounce and no program loading. I installed the xquartz X11 package, logged out, and Keepass loaded perfectly. Thank you thank you thank you!

      OSX 10.8.2

       
  • Hi
    you must change the permission on the file located in the applications folder.
    This helps on my side.

     
  • Xianthe Xian
    Xianthe Xian
    2013-01-17

    X11 was my issue!!! Thank you so much for listening! The permissions were fixed many posts ago.

    10.8.2 - X11 was not installed.

     
  • Joseph Celona
    Joseph Celona
    2013-01-18

    I finally got back to this, and X11 got KeePass working for me too. This should probably be noted on the Mac download page as a requirement as X11 is not installed with 10.8.2. Having said that, I've been playing with KeePass and have had a number of crashes, plus windows or parts of windows that have not rendered properly. I plan to use it more, but may end-up looking at another package, maybe one with a Mac-specific implementation.

    Thanks to Dave for the helpful reply,

    -Joe

     
  • Kcs Ray
    Kcs Ray
    2013-01-19

    I have the same problem. I use OS X 10.8.2. I have tried all the measures suggested above.I have installed:
    1.MonoFramework-MRE-2.10.10.macos10.xamarin.x86.dmg
    2.XQuartz-2.7.4.dmg
    3. Changed the permission level of the Keepass file KeePass2.20.1.dmg in the application folder.
    But nothing has helped. Every time I try to install it creates 0(zero) KB file.
    What is the problem? When the measures discussed above has worked for others, why it is not working in my system? or am I missing something?
    Thanks in advance for any help.
    -Kcsray

     
  • Dave Barreto
    Dave Barreto
    2013-01-19

    You need to change the permission ON THE 0 KB file. The reason it shows as zero kb (and with 'a do not enter' icon) is that you don't even have permission to read the file size or icon of the package. Once you add the permission to the file properly the icon and size will display properly.

     
  • Kcs Ray
    Kcs Ray
    2013-01-20

    It is done!!! Thanks you so much for your prompt help.

     
  • Openix
    Openix
    2013-01-23

    Hello,

    We have reworked the installation process for KeePass 2.20.1, which is now handled by a packagemaker installer. Please keep in mind (10.8) users that you will still receive a warning when GateKeeper is enabled, for that we need to sign the application with a certificate and that requires and Apple developer ID (annual fee: 99$) which is against the philosophy of open source software. However when we receive enough donations, we will buy a developer id and sign, so that you can keep your mac secure with GateKeeper.

    One of the coming weeks we will bundle the KeePass mono application, so that it runs standalone without the mono requirement, once we have reworked the interface to Cocoa, X11 of Xquartz is no longer needed.

    Work in progress ;-)

     
    • Hi Openix

      thank you for the effort!
      USD 33.- donated.

      Regards, Hans-Jörg

       
  • Dominik Reichl
    Dominik Reichl
    2013-01-24

    Please send donations for the Mac OS X package directly to Nico; the PayPal link can be found on http://keepass2.openix.be/ . The donation links on http://keepass.info/donate.html are for general donations to KeePass, not specific to the Mac OS X package.

    @Hans-Jörg: I'll forward your donation to Nico.

    Thanks and best regards,
    Dominik

     
  • choo.choo
    choo.choo
    2013-03-15

    $10 donated for the developer ID. I still can't run Keepass 2.20.1. I'm on OSX 10.8.2 and have installed X11 (XQuartz 2.7.4) and Mono (3.0.6). After I reboot, Keepass will start but as soon as I try to navigate to open a .kdbx file, it crashes. Thereafter it doesn't even start.

     
<< < 1 2 (Page 2 of 2)