Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Auto-Type Doesn't work on Vonage Home Page

Help
2005-11-20
2012-11-19
  • I must be missing something. I place my mouse cursor on the username field and select Perform Auto-Type and sometimes it does nothing and other times it will just to the password field and apparently puts both username and password in that password field. Whatever it is doing, its not working.

    What am I lacking in knowledge. I couldn't download the auto form as the site was down.

     
    • Sorry, for not answering your question directly.

      You could try KeeForm, available at

      http://keepass.sourceforge.net/plugins.php#formfiller

      In your example you would use

      cmd://KeeForm "http://vonage.com" {USERNAME} {PASSWORD}

      This fills your page withtout any Auto-Type and is very safe.

      If you want to click Submit / press ENTER automatically you could also use:

      cmd://KeeForm "http://vonage.com" {USERNAME} {PASSWORD} {ENTER}

      PS
      "please ignore the semicolon :-)

       
    • Thanks for responding.

      The Server is down for getting Keyform right now. I look forward to trying it as soon as it is up. I see a program called KeyWallet works off an automatic entry. I assume Keyform works similiar in nature. Cool stuff.

       
    • Not sure 100%, but KeyWallet also uses some kind of Auto-Typing (otherwise it wouldn't work with FireFox ...).

      KeeForm doesn't use any Auto-Typing for entering the password or username ("keylogger safe")

       
    • Paul
      Paul
      2005-11-22

      Works for me, either from the home page or from the login error page.
      Win XP SP2
      Firefox
      KP 1.03

      cheers, Paul

       
    • I am using IE 6. Maybe Firefox is the difference in yours working and mine not?

       
    • Paul
      Paul
      2005-11-24

      Yep, doesn't work with IE. Bloody Microsoft!!!  ;-))

      cheers, Paul

       
    • I tried it with KeeForm and it works fine (but KeeForm doesn't support Firefox :-)

      The download link for KeeForm works again.

       
    • I just tried my Vonage problem with FireFox and it worked fine. You were all right, that doesn't work with IE.

      I just downloaded KeeForm. Now to decide, do I stick with IE6 or Firefox? Firefox seems to load faster. Some of my context items don't show up on the context menu.

      I don't mean to make this a Firefox debate, but any recommendations?

       
    • Just checking on this syntax"
      cmd://KeeForm "http://vonage.com"; {USERNAME} {PASSWORD} {ENTER}

      I had to remove the {  } around my username and password for it to work on Vonage. Is that correct, you leave the brackets out?

      Thanks!

       
    • The syntax is

      cmd://KeeForm "http://vonage.com" {USERNAME} {PASSWORD}

      Let's say your username is "myuser" and "mypass"

      Did you try the following?

      cmd://KeeForm "http://vonage.com" {myuser} {mypass}

      If yes, that's wrong :-)

      Probably then you tried

      cmd://KeeForm "http://vonage.com" myuser mypass     

      Thatworks, but is better just to use

      cmd://KeeForm "http://vonage.com" {USERNAME} {PASSWORD}

      {USERNAME} and {PASSWORD} are Keepass symbols. When you double click on the URL, then Keepass automatically replaces {USERNAME} with myuser and {PASSWORD} with mypass.

       
    • Your really going the extra mile and I sure apreciate it.

      I've been on my pc all day so I maybe a bit tired, but here's what I tried:

      cmd://KeeForm "http://vonage.com" {myuser} {mypass}{enter}

      When I did the above, it would put {myuser} with the quotes into the username field of Vonage. Notice I did not include the ; as you mentioned much earlier in the thread not to. This last time it appears you are saying we should. Next I tried this:

      cmd://KeeForm "http://vonage.com" myuser mypass {enter}

      No brackets with myuser and mypass. And it worked. But I had one other headache. It wouldn't save those settings, but kept resetting the url to http://vonage.com every time I rebooted my pc. I figured with the option checked, "automatically save database on exit" that those settings would stick. Not until did I manually save the database did they show up when I rebooted my pc.

      This is a great program, but I've had to work at getting it to do what it should do because of my ignornace. Several times earlier I lost my data as it didn't save the changes.

      Don't give up on me! :-)

       
    • Looks like ; is generated during the post.

       
    • yes the following will work:
      cmd://KeeForm "http://vonage.com" myuser mypass

      But you should use _literally_ the following (without the semicolon ...)

      cmd://KeeForm "http://vonage.com" {USERNAME} {PASSWORD}

      You could also use

      cmd://KeeForm "http://vonage.com" {USERNAME} {PASSWORD} {ENTER}

      This way you ensure that you have to maintain your password only once in the password field in Keepass.

      Again {USERNAME} and {PASSWORD} are Keepass symbols. Don't think, that you have to replace them with your username and password. Keepass does this automatically.

      In the zip file at

      http://keepass.sourceforge.net/plugins.php#formfiller

      you can also find a small screenshot (example.png), that shows you how the entry should like.

       
    • Its works! I was misunderstanding the syntax with the {} to mean substitute my login and password in those.

      Vonage logged in fine now. {I noticed it put my username in the search field as well, but that had no practical ramifications.} It logged in fine.

      Once I am sure everything is stable with my other systray items, I'll be making a donation!