Using Autotype inserts a 1

Help
Anonymous
2011-02-01
2012-11-19

  • Anonymous
    2011-02-01

    When using Autotype on the Internet, I've noticed that it inserts a '1', then backspaces over it, types my username, tabs, then types my password and then sends that information.

    I first noticed this when I had created a custom entry so that I could have Autotype use two "username" fields.  Some of the websites I login to require a Company ID, Username and Password.

    If I set a delay of 50 {S:CompanyID}{DELAY=50}{TAB}{USERNAME}{TAB}{PASSWORD}{ENTER} the 1 still appears, but it will allow me to login properly.

    Am I going about using AutoType in this situation the wrong way? Has anybody else noticed this same issue?  I'm using 2.14\

    Thanks,
    Adam

     
  • Paul
    Paul
    2011-02-01

    This is by design. KeePass prepends characters if it detects IE as the browser window. This is to stop IE stealing the first couple of characters.

    cheers, Paul

     

  • Anonymous
    2011-02-01

    So the only solution then is to override the default login sequence and set a delay? (Other than using a different browser…)

     
  • Paul
    Paul
    2011-02-01

    You don't need to solve it, it's there to get around a problem caused by IE.
    If you really don't like it you can turn it off - Tools > Options > Advanced > Auto-Type > Prepend special initialization sequence for Internet Explorer Windows.

    cheers, Paul

     

  • Anonymous
    2011-02-01

    I guess the reason I'm asking is because without that delay it was giving me invalid credential messages, even though I have the proper user name(s) and passwords and have verified that by manually typing the information in.

     
  • Paul
    Paul
    2011-02-01

    Why would typing a 1 and then a backspace give you invalid credentials? Try it by typing those characters first.

    cheers, Paul

     

  • Anonymous
    2011-02-01

    The first time I tried it, I did get an invalid credentials message.  After that I wasn't able to recreate it.  If I add {DELAY=50} or {DELAY=100} even without prepending the IE windows sequence, everything works perfect.

    Thanks for your help, Paul.

     
  • Paul
    Paul
    2011-02-01

    The site may have JavaScript that runs when you type, but it isn't fast enough to keep up with the KeePass default speed?

    cheers, Paul

     
  • Parker
    Parker
    2011-06-05

    open keepass database.  go to advanced tab. scroll down  to auto-type. uncheck  "Prepend special initalization sequence for internet explorer windows". save file. Should stop the 1 apearing then being deleted.

     
  • Greg
    Greg
    2012-06-24

    Here is an example of where the Keepass "Prepend special initialisation sequence for Internet Explorer windows" function fails, and how I worked around this problem.

    I use a banking website that requests a selection of 3 random characters each from my PIN and Password, requiring one character for each of the 6 sequential controls.

    When a key is pressed the website automatically moves the cursor to the next control (i.e. I do not need to press TAB).

    Hence, when I try to simulate this by using the following custom keystroke sequence:-
    {PICKCHARS:PIN:C=3}{PICKCHARS:Password:C=3}{ENTER}
    …the simulation fails, as Keepass automatically types the character “1”, then immediately the website moves to the next control. My 6 chosen characters are all out of sequence by one place each.

    I did not want to globally disable the Keepass "Prepend special initialisation sequence for Internet Explorer windows", so I resolved the problem by changing my custom keystroke sequence to:-
    +{TAB}{DELETE}{PICKCHARS:PIN:C=3}{PICKCHARS:Password:C=3}{ENTER}

    This is how this new sequence works:-

    After I have selected my 6 random PIN and Password characters from the 2 character picking dialogs, Keepass then prepends the character “1” in the first control. The website then moves to the second control, and I suspect Keepass tries to perform a BACKSPACE, but this has no effect.

    Next a SHIFT TAB (i.e. +{TAB}) moves the cursor from the second control to the first control, and then the Keypass  prepended character “1” is deleted (using {DELETE}).

    Finally all my 6 PICKCHARS characters are entered into the correct 6 controls, and I continue to the next banking webpage with an {ENTER}.

     
  • Paul
    Paul
    2012-06-25

    Nice workaround!

    cheers, Paul