KeePass 2.24 does not load plugins on openSUSE 13.1

  • David Lechner
    David Lechner
    2014-01-13

    There is a bug in Mono 3.0.x where plgx plugins will not compile correctly. The resulting dll that is produced is missing essential information and KeePass will not recognize it.

    Your options are to upgrade or downgrade Mono or compile the plugins on a different system (Windows or different Mono version) and copy the resulting files from the plugin cache to your KeePass folder. I have done this for KeeFox/KeePassRPC, but not for other plugins.

    Dominik, you should add a note on the KeePass 2.x system requirements that plgx type plugins will not work on Mono 3.0.x.

     
    Last edit: David Lechner 2014-01-13