Keepass autotype not working

Help
Allan
2011-11-05
2012-11-19
1 2 > >> (Page 1 of 2)
  • Allan
    Allan
    2011-11-05

    Win 7 HOme Prem
    Keepass 2.16
    Chrome browser

    Auto type LCtrl + Alt + A
    works in test with Notepad
    does not work with a web page

    Ctrl V works with web page, but is not so convenient as need to make Keepass window active to use
    Do not have Vmware
    read posts on this forum for similar problem, but no solution there for me
    Any ideas

     
  • Allan
    Allan
    2011-11-06

    Yes, if you mean try LCtrl-Alt+A in a notepad document as outlined where you  pointed me to.

    Have noticed that I get windows default beep  when I do type Ctrl Alt A on an open web login  page

    I have checked - there is a the title entry in Keepass does contain a word that is in the web page tab (not the url)

     
  • Donna Manley
    Donna Manley
    2011-11-07

    I have tried v2.15, v2.16 and v2.17 on my Windows 7 Ultimate box
    AutoType doesn't even work in Notepad, much less in a browser.

    AutoType (Control-V) is one of my favorite features of KeePass.
    I hope you can get it working again.

    Thanks,
    Donna

     
  • Allan
    Allan
    2011-11-07

    Donna

    Control -V does work for me, but Global AutoType LCrl-Alt-A does not, but Ctrl-V is so inconvenient as I don't often open a web page from Keepass, and having to give focus back to Keepass to fnd the page I want to open is a bit of a pain.

    Are you saying that you can't even get Control-V to work?

    Did you open the login page, then return to Keepass and select the web page item there and then hit Control-V while Keepass has focus?

    If you try this with Notebook, you may find that AutoType will put in the password for any website that is selected in Keepass when you hit Ctrl-V

    Allan

     
  • Allan
    Allan
    2011-11-07

    Paul,

    Maybe I need to clarify.  Global AutoType works in Notepad test, but not in a web page.

    AutoType  Crtl-V works in Notepad and in web page.

    But I find Crl-V method clumsy and inconvenient.

    I wonder if it is a Windows thing because Global AutoType (Ctrl-Alt-A)  works just fine on my Ubuntu 11.04 laptop under Mono.

    Allan

     
  • Donna Manley
    Donna Manley
    2011-11-07

    Paul,

    I understand that my issue is different from Allan's. I didn't know how to start a new thread, so I jumped into this one. If you would rather I move elsewhere, please help me know how to do that.

    I have been using KeePass for many years, and understand how the Ctrl-V autotype is supposed to work. It still works on my laptop, which is Windows XP and KeePass v2.10

    AutoType is NOT working on two other machines for me. Both are Windows 7 Ultimate with KeePass versions 2.15 and above.

    Thanks,
    Donna

     
  • Paul
    Paul
    2011-11-07

    Allan, if it works in Notepad you most likely haven't got the match right or you don't have the cursor in the correct field on the web page. Try the test page here: http://keepass.info/help/kb/kb090406_testform.html

    Donna, try running KeePass as administrator - right click on KeePass.exe. Alternatively turn UAC off.

    cheers, Paul

     
  • Allan
    Allan
    2011-11-08

    Paul

    Looks like Global AutoType does work after all.  At least on the 5 pages I just tried  - except for the one which I have been trying all along.  Still can't get it to work on that one!!   Well at least I know it works- I'll keep looking into that one case, or maybe I'll find some others that don't work and then maybe something in common will show up

      thanks for the quick and useful replies

    Allan

     
  • Donna Manley
    Donna Manley
    2011-11-08

    Paul,

    I tried with the right-click and Run as administrator. Same results. I click in an empty notepad window, then Ctrl-V on my Keepass entry, and nothing is auto-typed.

    Do you think there might be something wrong way at the top, and all of the groups and entries are inheriting some bad setting?

    Donna

     
  • Paul
    Paul
    2011-11-08

    Allan, if you tell us which web site we can test for you.

    Donna, pressing Ctrl V with KeePass in focus will Auto-Type the highlighted entry. Try right clicking on the entry and select Perform Auto-Type.

    cheers, Paul

     
  • Donna Manley
    Donna Manley
    2011-11-08

    Paul,

    Good diagnostics … Here are my results.
    - I opened KeePass
    - I  opened a blank Notepad window and clicked in it
    - I right-clicked a KeePass entry and chose Perform Auto-Type 
    - Nothing appears in Notepad

    Tried this for 5 or 6 items - same result.

    What should we try next?

    Donna

     
  • Allan
    Allan
    2011-11-08

    Paul,

    Global AutoType now works for all web pages - don't  know how, but I must have made an error in the site tab name - it was only one word  "home" so not sure how I could screw that up!

    thanks for the added attention,
    Allan

     
  • Paul
    Paul
    2011-11-09

    Donna,

    Do you have data in the user name and password fields of the entries?
    Open the KeePass test page and try to drag n drop the user name and password.
    http://keepass.info/help/kb/kb090406_testform.html

    cheers, Paul

     
  • DrDOS
    DrDOS
    2011-11-10

    I have the same isssue.  Site http://www.tnthelpforum.com/tmec/ucp.php?mode=login and get
    You have specified an incorrect password. Please check your password and try again..  When I type in manually all ok.  Used to work fine.  Not sure when.  Sorry. 

    Blank notepad file shows correct info.  When password is typing, seems to be long. ??

    Thanks

     
  • Paul
    Paul
    2011-11-11

    There is a lot of javascript on that page that may be the issue. Does drag n drop work?

    cheers, Paul

     
  • DrDOS
    DrDOS
    2011-11-11

    Paul,

    Yes.  I can cut and paste user/pass or type manually.  Your test page http://keepass.info/help/kb/kb090406_testform.html works as well.

    I'm stuck until they fix their page or is their another option I can suggest?

    Thanks.

     
  • Paul
    Paul
    2011-11-12

    Try adding an inter key delay to the Auto-Type.
    {DELAY=100}{USERNAME}{TAB}{PASSWORD}{ENTER}

    cheers, Paul

     
  • DrDOS
    DrDOS
    2011-11-12

    Paul,

    Thanks for that.  (Now I know why there is an alternative to Ctrl+V.  Wondered about that until now.  Awesome!)

    Tried 200 as well,  I will keep playing with the numbers. 

    I get a "1" typed before the username and it is immediately deleted.  When the password is typed, seems too long, but all I see are dots (of course). 

    Your test page works fine as well as notepad.  I created a .wmv file of what I'm seeing but not sure how to send.  Use program Screen Recorder.

    If playing with the numbers gets it to work, I'll repost.

    Thanks for hanging.

    Drew

     
  • DrDOS
    DrDOS
    2011-11-12

    Paul,

    Hmmm.  If this is a site I've been to before, and it has cached my password (as it does my username), is the password on the site added to or replaced with what is there?

    I think my password is being input twice.  Once from the cache and once from Keypass.  That's why it works on test page and in notepad - nothing stored.

    I hope I made sense.

    Drew

    **I just tried it (cleared cookies and passwords in IE9) and no joy!  But password typed seemed shorter!  Fiddlesticks!!**

     
  • Paul
    Paul
    2011-11-12

    Try leaving out the Enter so you can see how many characters are typed.
    {DELAY=100}{USERNAME}{TAB}{PASSWORD}

    The characters added and deleted are to work around an issue where IE would lose the first character.- Tools > Options > Advanced > Auto-Type.

    cheers, Paul

     
  • DrDOS
    DrDOS
    2011-11-12

    Well, it worked, sort of.  Thanks for the tip.

    The correct number of characters is being typed.

    If I delete the cached username/password, it seems to work.  (I swear it didn't before!  :winkgrin )

    If I leave alone, password is added to cached password. 

    Can the password be cleared each time?  Is there a way to add a {SHIFT}{HOME}{DEL} to the sequence?  I tried and didn't work this way.

    Is this an IE9 issue?  I don't remember this happening until recently but I've been using IE9 for a while.

    I turned off the remembering of passwords and put back {ENTER}.  All seems to be working as expected!

    I guess lesson here is

    • don't cache passwords, esp if you use programs such as this.

    • use auto-type feature to troubleshoot.  lCtrl+Alt+A as opposed to Ctrl+V

    • use test area provided by Keypass http://keepass.info/help/kb/kb090406_testform.html

    • use Notepad for testing

    • Remove {ENTER} from auto-type to stop login from continuing

     
  • DrDOS
    DrDOS
    2011-11-12

    Thanks for your help Paul.  Sorry for the large size above.  Next time I'll use something smaller.  Just wasn't sure what was expected.

    Take care.

    Drew

     
  • wellread1
    wellread1
    2011-11-12

    The auto-type fragment {HOME}+{END} can be useful for sites that cache data such as usernames.  I include it in my default auto-type so I never have to worry about whether the site caches usernames or not.

    For example: {HOME}+{END}{USERNAME}{TAB}{HOME}+{END}{PASSWORD}{ENTER}  will select the contents of a field and overwrite it with {USERNAME}, then tab to the next field, select its contents and overwrite it with {PASSWORD}

    -wellread1

     
  • wellread1
    wellread1
    2011-11-12

    {CLEARFIELD} also works but is not supported in some earlier versions of KeePass 2.x

    -wellread1

     
1 2 > >> (Page 1 of 2)