Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Auto-Type not working if VMware console open

Help
Anonymous
2010-07-21
2013-01-21

  • Anonymous
    2010-07-21

    I am having an issue with KeePass not auto-typing if a VMware console is open on my desktop.  If a VMware console has taken focus of my keyboard and mouse (and subsequently returned focus to windows) KeePass auto-type will not work until the VMware Console has been closed.  This problem happens when i try the Control,Alt+A hotkey and when i right click on a KeePass entry and select Perform Auto-Type.

    I can consistently reproduce the problem as follows:
    1. open KeePass and a browser - auto-type works
    2. open a VMware Client tool (vSphere Client or Server Client) - auto-type works
    3. open a virtual console in the VMware client tool - auto-type works
    4. give focus to the virtual console (click in it and type anything) and then press ctrl+alt to give focus back to windows - autotype failes
    5. close the virual console - auto-type works again.

    When auto-type is in a not working state, my mouse is unresponsive for a short period of time as if auto-type was typing.

    Is this a bug in KeePass or VMwares tools?  has anone else seen this or found a workaround other than closing consoles before auto-typing a password?

    I used the following products to test with:
    KeePass 2.12
    VMware vSphere Client 4.0.0
    Mozilla Firefox 3.5.10

     
    • danielreid
      danielreid
      2013-01-21

      I am to reproduce the same issue, wherein having a VMClient open (in IE) prevents Auto-Type from operating in my regular browser (Chrome).

      If I close the VMWare window, auto-type starts working immediately.

      Versions:
      KeePass 2.20.1
      vCenter Lab Manager 4.0.3.1318
      Internet Explorer 8
      Chrome 24.0.1312.52 m

       
      Last edit: danielreid 2013-01-21
  • Paul
    Paul
    2010-07-21

    Does it happen if VMware tools is installed in the guest?
    I'll try and test this tomorrow.

    cheers, Paul

     

  • Anonymous
    2010-07-21

    It happens from the VM's command line login with and without vmware tools, and from the VM's GUI with vmware tools installed.  I don't have a VM with a GUI and without vmware tools at the moment but I could create one if it'd help.

    Ryan

     
  • majik
    majik
    2011-03-04

    I experience the exact same problem. It can get annoying if I need KeePass for other applications but still need vSphere open. I would like to add that when auto-type is not working, KeePass does give focus to the previous window that needs the auto-type, but the keystrokes aren't going through.

    I am currently using:
    KeePass 2.14
    VMWare vSphere Client 4.0.0 Build 208111
    Mozilla Firefox 3.6.10

     
  • majik
    majik
    2011-04-20

    KeePass 2.15 seems to have resolve this issue. Ryan Falkenberg , can you confirm? Paul, I didn't see anything in the change log that mentions anything related to this. Nonetheless, it seems to be working now. Thanks!

     

  • Anonymous
    2011-04-20

    I'm having a similar problem, and KeePass 2.15 did not resolve it. Using VMware View to connect t a VM machine.

     
  • majik
    majik
    2011-04-21

    OK I take it back. It doesn't work after all. It only works when the VMWare vSphere Client is initially opened. But once I start logging on to VM's, KeePass Auto-Type stops working.

     
  • Diana Gallegos
    Diana Gallegos
    2011-05-04

    I am so glad you posted this information!  I am having the same problem using VMWare VSphere Client 4.0.0 also.  My KeePass is at version 2.15.  This problem was driving me crazy-I didn't know why KeePass would work and then suddenly not work.  Now I know to exit out of VSphere Client.  Thanks!

     
  • desolat
    desolat
    2011-06-29

    I could workaround the problem like this:

    I'm using the plugin RDCAutoTypeAndTCATO 0.6.1.0 . Auto-Type with did not work when the vSphere Client was open. When I disable the RDCAutoTypeAndTCATO option "RDC workaround enabled" Auto-Type on the local machine is working.

     
  • phatair
    phatair
    2011-09-14

    I have the same problem. If i connect to a virtual machine with the vsphere client the auto-type function is not working. if i close the console (connection) to the virutal machine auto-type is working. The problem is not the vsphere client, it is the connection to the virtual machine with the vsphere client.
    the solution with the rdc autotypeandTCATO is not working for me

     
  • Paul
    Paul
    2011-09-15

    Does KeePass V1 work?

    cheers, Paul

     
  • Corvidrue
    Corvidrue
    2011-09-16

    Glad I found this topic I was going crazy trying to figure out why AutoType wasn't working.

    I can confirm that I do not have this problem when using a portable (stand alone not installed) version 2.09

    however I do have this exact problem when using either installed or portable version 2.16

    hope this helps

    Thanks.

     
  • phatair
    phatair
    2011-09-19

    Yes i can confirm this - version 2.09 works with vsphere client.
    it would be great if this "bug" in the 2.16 can be fixed.

     

  • Anonymous
    2011-09-23

    Yes 2.09 seems to work fine!

     
  • Paul
    Paul
    2011-10-26

    Try the RDCAuto-Type plug-in. This bypasses the .NET sendkeys routines.

    cheers, Paul

     
  • Manu
    Manu
    2011-11-14

    Hi, I as have the same problem with 2.17.
    Is there a workaround?
    Do we have to downgrade to 2.09?

    Tks

     
  • Tony Sanders
    Tony Sanders
    2012-03-18

    RDCAuto-Type plug-in didn't fix this issue for me. It has however been fixed by VMware in vSphere 5.0

     
  • majik
    majik
    2012-03-20

    Paul,

    Auto-type does NOT work with vSphere 4.0 and KeePass v2.218.
    Auto-type does work with vSphere 4.0 and KeePass v1.21.
    Auto-type does work with vSphere 4.0 and KeePass v2.218 and the RDCAuto-Type plug-in.

    I don't have vSphere 5.0 so I can't confirm if the issue is resolved as tiggerb stated.

    phatair, in post #10 you mentioned the RDCAuto-Type plug-in didn't work for you. Be sure to add the executable's filename of the program you're trying to use auto-type on. For instance, I was testing it with a website in Chrome. I added chrome.exe to the program list (go to menu TOOLS > RDCAuto-TypeAndTCATO > Programs List…).