Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

KeePass Auto-Type Failing when Locked in 1 app

Help
2013-09-30
2013-10-05
  • Using version 2.23

    I've been using the auto-type feature of KeePass for a quite a while with a variety of sites and games without issue. My workspace locks after a short period, so typically, I have to enter the master password when I activate auto-type.

    In Final Fantasy XIV, if my workspace is locked, auto-type only puts in 2 characters of my password. I can click back in the box, delete those 2 characters and activate auto-type again and the password goes in without an issue.

    I've tried setting a delay before the password and I've tried a delay between each character (painful to wait on). Is there something else I should try so I can get auto-type to work correctly in this app?

     
  • wellread1
    wellread1
    2013-09-30

    If you have TCATO enabled for the entry, try turning it off. Edit Entry(dialog)>Auto-Type(tab)>uncheck Two-channel auto-type obfusation(lower left corner)

    If that is not the trouble you will need to do some additional testing. Start by setting up the web site login so that you must enter the username. At the very least you will be able to see the initial typing (2 dots in a password field is not very informative). Once you can see how the auto-type is failing, it is usually straightforward to fix the auto-type.

    Note: You didn't mention the site URL but I didn't see any issue with an auto-type at unlock using dummy login credentials at the login reachable from http://na.finalfantasyxiv.com/lodestone/.

     
    Last edit: wellread1 2013-09-30
  • Thanks, I'll give that a shot.

    It's not a URL, but the launcher itself.

     
  • I turned off TCATO and when I do that, nothing is typed into the password block when KeePass is locked.

    If it's unlocked, it pastes the correct thing. When TCATO is turned on, it only types the first 2 characters of the password (I started in the login box instead).

     
  • wellread1
    wellread1
    2013-10-04

    What about the the username block? What is your auto-type sequence?

     
  • AlexVallat
    AlexVallat
    2013-10-05

    It may just be that the launcher app is badly written and doesn't put the keyboard focus back in the password box when the window returns to foreground.

    For another irritating example you can try without having to install FF XIV, try http://game.cardhunter.com/. If you have to unlock KeePass then the browser loses focus (as the unlock dialog becomes foreground), but then when the unlock dialog goes away and the browser becomes foreground, the keyboard focus is no longer in the username (or password) box.

    Alex