Default Password Entry // import CSV file

Help
2004-11-27
2012-11-19
  • Hello,

    I've 2 questions:

    1) I would like to have an empty password field if I add a new password. Is this possible?
    2) I dedicated almost 2 hours to import my passwords in
    Keepass. Finally I have them in my Keepass but I noted that keepas does not do anything with the /n option in comments. I have a lot of "n" characters in the comments fields. How can I let Keepas recognize these /n characters?

     
    • What do these characters do? An example please?
      cheers, Paul

       
    • You don't know the /n command?
      That's the "new line" command.

       
    • Newlines are imported as newlines, not /n. You need to make sure all the text is within quotes, e.g.
      "A note with a new line.
      2nd line of note"
      cheers, Paul

       
    • Paul, I don't understand what you try to tell me. In CSV new lines are almost always indicated with /n or \n.
      I have exported my passwords in a CSV command so every account has only one line. My comments are with /n (linebreak).

      What about the default Password entry. Nobody can answer me? I would like to have an empty password field as I add an account/entry.

       
    • Keepass imports line breaks, not /n. It may not be standard CSV, but that is what it does.

      cheers, Paul

       
    • Can you give me an example what you mean?

      My CSV file has to be like this:

      "My_account","My_Username","My_Password",
      "My_URL","1 line of comments/notes
      2 setence line bla bla bla
      3 line bla bla bla"

      Is that right?
      If this is correct I cannot export my passwords to Keepass because my actual password manager (oubliette) does export line breaks with "/n" character but do not know how to adapt the file as above.

      Regards,
      Ray

       
    • As much time as you've been trying to do this you could have long ago entered your info into the program manually...

       
    • Yes, but if I could do this I would not insert a message here, so is there someone who gives me an answer please!!!!

      (I have 300 password with pages of comments with many passwords so don't give me that kind of answers please).

       
    • If I could do this I would not insert a message here so please don't lose your time with these kind of answers.
      (I have 300 passwords with most of them many many lines of notes).

      Please is there anyone who can answer my question?

      Ray

       
    • CSV requirements.
      The first line is required to specify fields.
      Other lines are the data.

      "Account","Login Name","Password","Web Site","Comments"
      "My Bank","Accountloginname","supersecretpassword","http://www.mybank.com","1st line of note.
      2nd line of note.
      3rd line of note
      Auto-Type: {USERNAME}{TAB}{PASSWORD}{TAB}{ENTER}"

      There seems to be no way to specify groups and when you import it imports into the highlighted group. So I suggest you make a test group, import into that, then sort manually.

      cheers, Paul

       
    • Thank you very much Paul!

      Cheers,
      Ray

       
    • Well I've decided not to switch to Keepass.
      It is impossible for me to change every "/n" as line break.
      I think that the import function is too bad and too complicated. I'll wait an upgrade of Keepass.

      However, thank you Paul for your help.

       
      • Dominik Reichl
        Dominik Reichl
        2004-12-05

        ... It's not that hard to replace all /n by newline characters...

        1) Start Microsoft Word and open your CSV file
        2) Go to Edit - Replace
        3) Enter "/n" (without the "") as search string
        4) Enter "^a" (without the "") as replace string
        5) Enable the "Pattern comparison" checkbox
        6) Click "Replace All"
        7) Save and close everything (of course make sure you save it as text file, not as Word document)

        Alternatively, under Linux, you can just do a regex search and replace.

        Best regards,
        Dominik

         
    • Dear Dominik,

      I've replaced "\n" with "^a".
      Then I've imported the all (without Auto-Type: {USERNAME}{TAB}{PASSWORD}{TAB}{ENTER} because I do not know how to add this and what it means).

      However in the comment field there are now all "^a" and no line breaks. :-(

       
    • Dominik,

      Your suggestion doesn't work.
      What to do?

       
    • Dominik Reichl
      Dominik Reichl
      2004-12-07

      Get some text editor with regular expressions support, like TextPad (http://www.textpad.com) or UltraEdit (http://www.ultraedit.com). Then, replace all /n with the regex sequence for a newline character.

      Best regards,
      Dominik

       
    • Thank you.
      But it didn't work.

      I stop keeping me busy with let Keepass work.
      Will wait next release.
      Hope that you change import function.

       
    • In regular expressions:

      \n = new line
      ^a = everything except "a"

      You told me to change all "\n" with "^a" (?????)

      Why don't you write me that there's no possibility to import text with "\n"  (newline) characters?

       
    • Dominik was almost correct.
      4) Enter "^p" (without the "") as replace string

      cheers, Paul

       
    • Does not work as well!

       
    • Works for me, you must be doing something strange.

      cheers, Paul

       
    • Please gives us in the next release an option menu when importing CSV files  (comma or tab field, line breaks indication etc.etc.).

      I did all the work manually yesterday. About 2 hours of work but have now "resolved" this question.