Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Auto Type doesn't work anymore

Help
mp909012
2013-05-16
2013-05-31
  • mp909012
    mp909012
    2013-05-16

    Recently Auto Type stopped working and i can't figure out why.
    I'm using KeePass 2.22, but also went back to 2.21 to check its not because of the latest version.

    When i try to use Autotype it looks like it is doing something but nothing happens.
    I get a selection dialog if i have several entries matching so i know the hotkey works.

    I have the same behavior when i try to use CTRL+V from within KeePass.

    I can't even paste something into Notepad.

    Any ideas who to find the issue?

    BR
    Michael

     
  • Paul
    Paul
    2013-05-17

    Have you installed any other software recently?
    Test a new version of KeePass by copying KeePass.exe to a new folder and then double clicking on it and creating a test database.

    cheers, Paul

     
  • mp909012
    mp909012
    2013-05-17

    Hi Paul,

    I tried it with a empty folder, only KeePass.exe and create a new DB.
    Auto type to notepad doesn't work, it changes focus to notepad but nothing is typed.
    I'm not sure about software, my original feeling was it started with the update to 2.22 but i'm not sure.
    Can a KeePass plugin interfere?
    I have the folowing installed:
    KeeOTP 1.3.1
    FavIcon Downloader 1.6.0.0
    KeePAss Pronounceable Password Generator 1.0.4.0
    KeePassRPC 1.2.3.0 (for KeeFox, which i use as a work around for the moment)

    Altough then the new KeePass should work.

    Thanks
    Michael

     
  • Paul
    Paul
    2013-05-18

    It is unlikely to be a KeePass plug-in, but you tested with only KeePass.exe so no plug-ins.
    Maybe your anti virus won't let KeePass type?

    cheers, Paul

     
  • mp909012
    mp909012
    2013-05-18

    Hi Paul,

    the only virusscanner runnig is windows 8 windows defender.
    I tried to stop Realtime Protection to see if it makes a difference and it behaves the same. Change focus to app but no typing.

    Any other ideas how to narrow this down?

    Thanks
    Michael

     
  • Paul
    Paul
    2013-05-20

    Try running KeePass as admin. Hold Shift down and right click on KeePass.exe, choose Run as administrator.

    cheers, Paul

     
  • mp909012
    mp909012
    2013-05-20

    Hi Paul,

    sorry that also didn't make a difference. I tried the following combinations:
    1. Original KeePass + original DB , Windows defender on
    2. Original KeePass + original DB , Windows defender off
    3. New KeePass + new DB , Windows defender on
    4. New KeePass + new DB , Windows defender off

    All started as Administrator.

    I tested on Autotype to notepad and it always changed focuse to notepad (or put itself in the background) but never typed anything...

    Thanks
    Michael

     
  • Paul
    Paul
    2013-05-20

    All I can suggest is to copy your version of KeePass to a USB key and test it on another computer.

    cheers, Paul

     
  • mp909012
    mp909012
    2013-05-23

    Hi Paul,

    I tried it now on a Win7 64bit laptop and auto type works fine there.
    Is there a "debug" build or a commandline switch to enable logging to find out whats going wrong on my computer?

    I copied the original KeePass folder + DB.

    Thanks
    Michael

     
    Last edit: mp909012 2013-05-23
  • Paul
    Paul
    2013-05-27

    Not to help with that problem.

    Try the RDCAutoTypeAndTCATO plug-in to see if that works. Then try repairing the .NET installation in case that's a problem.

    cheers, Paul

     
  • mp909012
    mp909012
    2013-05-27

    Hi Paul,

    I tried the plugin but it didn't seem to help.
    Also not 100% sure what exactly to do with it. I added notepad.exe into the progam list to see if TCATO makes a difference.

    As to repairing the .Net install I'm not sure how... It comes with Win8 so no entry in the "Programs and Features" and i tried to google it but didn't come up with anything for Win8...

    Thanks
    Michael

     
  • wellread1
    wellread1
    2013-05-27

    Have you tried booting to safe mode and testing there?
    Do you have any restore points that predate the beginning of your problem and that you can roll-back to?

     
  • mp909012
    mp909012
    2013-05-31

    Hi Paul,

    Thanks for your help! I found the problem now.
    After restarting in Safe Mode Auto-Type worded as expected.
    So after establishing that i started to systematicaly stop app and services that are started automatically at run time.
    I post the results here also for the benefit of others.
    For my Synergy (a tool which allowes you to use your mouse and !Keyboard! on several PC at the same time) must somehow capture the Keys before they actually get send the the target window. Not sure how to go from there...
    Funny thing is that I use both tool for a long time and until recently never had problems.
    I think I updated Synergy not too long ago as well but totally forgot about it. So the new version there must have introduced the problem.

    Again Thanks as lot Paul for your help and patience with me!

    Regards
    Michael

     
  • Paul
    Paul
    2013-05-31

    Nothing like detailed systematic fault finding. :)

    cheers, Paul