Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Pb with autotype

Help
Luc
2014-02-16
2014-02-25
  • Luc
    Luc
    2014-02-16

    Hi,

    I am just starting using Keepass with keeform on firefox, having a problem with autotype.
    I have a problem when I click a URL fron keepass GUI.
    Bizarrely, it worked a few times, but now it looks broken.
    I think the autotype works fine, because I can see very briefly the page I am expecting after logging in, but it is systematicall replaced by an empty tab almost immediately

    Also, when I go in the keepass config, it shows that Ctrl Alt A can be used to fill the form, but this does not work at all, but I am not sure this is supposed to work that comes with keeform ??
    Any suggestions ?
    Thanks for helping

     
  • wellread1
    wellread1
    2014-02-16

    I have a problem when I click a URL fron keepass GUI.
    Bizarrely, it worked a few times, but now it looks broken.

    When you click on a URL in Keepass, it will open the specified web page but will not automatically fill it in.

    The third-party application KeeForm (or similar) is required for form filling.

    Also, when I go in the keepass config, it shows that Ctrl Alt A can be used to fill the form, but this does not work at all, but I am not sure this is supposed to work that comes with keeform ??

    When you press the Global auto-type key (default Ctrl-Alt-A) one of the Window Title matching methods that KeePass uses must find a match between the Window Title (in a browser this is the Tab title, not the URL) and a Target Window string defined in a KeePass entry. The simplest, and default, method of matching is to check whether:

    The title of the KeePass entry is a substring of the currently active window title.

    If the above criteria is met, KeePass will start typing the default keystrokes (auto-type sequence) into the active window beginning from the cursor position in the active window.

     
  • Paul
    Paul
    2014-02-17

    To see if it is KeeForm causing the problem disable it for the entry you are having trouble with. See the "Disable" FAQ.
    http://keeform.org/keepass/faq

    cheers, Paul

     
    • Luc
      Luc
      2014-02-17

      Thanks for answering,
      In fact, the problem I was describing went away with no apparent reason, I assume this is something I did, but I really don't see what it could be.
      I will now try to have the Ctrl+Alt A working, based on Wellread1's infos.
      BTW, I noticced that keeform is not always able to correctly detect the form to fill, would you advise another apps that works more reliably ?

       
  • Paul
    Paul
    2014-02-18

    KeeForm uses a relatively simple mechanism and this works most of the time. When it fails you can just use Auto-Type tailored to your particular requirements. (I you can tell us what site you are having trouble with we can suggest an Auto-Type sequence.)

    cheers, Paul

     
  • wellread1
    wellread1
    2014-02-19

    If you are using KeePass without KeeForm, a simple auto-type works fine on live.com sites.

    When both the usename and pasword are empty, the simplest auto-type works:

    {USERNAME}{TAB}{PASSWORD}{ENTER}

    To see what is happening during auto-type, slow it down by adding a 100 ms per keystroke delay; and/or add a 2000 ms delay between typing the username and password. Notice that the "=" determines how DELAY works:

    {DELAY=100}{USERNAME}{TAB}{DELAY 2000}{PASSWORD}{ENTER}

    If the username and/or password is already filled out add {CLEARFIELD} or {HOME}+{END} clear the occupied field during auto-type:

    {CLEARFIELD}{USERNAME}{TAB}{PASSWORD}{ENTER}
    {HOME}+{END}{USERNAME}{TAB}{HOME}+{END}{PASSWORD}{ENTER}

     
  • Luc
    Luc
    2014-02-19

    I am not sure to understand what you mean.
    I tried to copy the sequence {CLEARFIELD}{USERNAME}{TAB}{PASSWORD}{ENTER} in the notes field, it did not work better, both fields are left empty
    Is that what you suggested ?

     
  • wellread1
    wellread1
    2014-02-19

    What version of KeePass are you using?

    In KeePass 2.x to override an entry's default auto-type: Select the entry's Auto-Type tab, select "Override default sequence"; Replace the specified sequence with the desired sequence.

    In KeePass 1.x preface the auto-type with "Auto-Type: "; place it on a dedicated line in the Notes section; e.g. Auto-Type: {CLEARFIELD}{USERNAME}{TAB}{PASSWORD}{ENTER}

    To see how auto-type works, create a KeePass entry called "test" (without the quotes) and try to auto-type on http://keepass.info/help/kb/testform.html. Make sure the cursor is in the "User name:" field before briefly pressing Ctrl-Alt-A.

    See the auto-type help for additional details on how to define auto-type sequences in the two major versions of KeePass.

     
  • Luc
    Luc
    2014-02-24

    Hi,

    I am using keepass 1.26 with keeform
    I tried to add the line below in the note field:
    Auto-Type: {CLEARFIELD}{USERNAME}{TAB}{PASSWORD}{TAB}{TAB}{ENTER}
    When I start the site by clicking the URL in keepass (which works fine all my other sites), I alllways get the same result: an error message specifying the format of the email address, as if the one entered by keepass was incorrect.
    And if at this point I type Ctrl+Alt+A, it has strictly no effect.
    I also tried to add {DELAY=1000} before the sequence: strictly no effect.

    But at this point if, in keepass, I select the entry and right click "perform auto-type", it works as expected, with the correct delay. In fact, that's the only way that works with this site.
    In fact, it seems that the site URL is not recognized by keepass, I have to explicitely select the entry in keepass to make it work

     
  • wellread1
    wellread1
    2014-02-24

    When I start the site by clicking the URL in keepass (which works fine all my other sites), I alllways get the same result: an error message specifying the format of the email address, as if the one entered by keepass was incorrect

    If the error is occurring as a result of the clicking on the URL the problem is probably a malformed URL in the URL field.

    And if at this point I type Ctrl+Alt+A, it has strictly no effect.
    I also tried to add {DELAY=1000} before the sequence: strictly no effect.

    Ctrl-Alt-A will not trigger an auto-type unless either the entry's title is contained in the Window Title (for browsers, the tab title is the Window Title) or if a Target Window (aka Auto-Type-Window) has been defined in Notes that matches the webpage browser's Window Title.

    But at this point if, in keepass, I select the entry and right click "perform auto-type", it works as expected, with the correct delay. In fact, that's the only way that works with this site.

    Perform auto-type is a different kind of hot-key. It triggers auto-type without requiring Window Title matching.

    You may wish to review the auto-type help page

    In fact, it seems that the site URL is not recognized by keepass, I have to explicitely select the entry in keepass to make it work

    That is correct. KeePass does not match URLs. If you wish to use the URL to trigger an auto-type you need to use one of the auto-type aid or form-filler plugins.

     
  • Luc
    Luc
    2014-02-24

    I got lost here, I thought that keeform was a form-filler plugin, isn't it the case ??
    What is for sure, is that for all my other URLs, I just have to click on the URL in keepass to have the site open and the form filled, this hotmail site is the only one that does not work.
    BTW, I added "Auto-Type-Window: Connexion - *" in the notes field, and the Ctrl+Alt+A now works, at least that's a progress.

     
  • Luc
    Luc
    2014-02-24

    I just tried to disable keeform for this site, and I no longer have the error message I was mentionning earlier.
    So it seems that in this case, keeform tries to fill the form, but fails to do it correctly

     
  • Paul
    Paul
    2014-02-25

    KeeForm is the form filler and that is where you have a problem. I don't know how to modify the KeeForm form filling to fix your issue, so disabling it is easiest until you can work out a fix.

    cheers, Paul