Auto-type disabled

Help
Zach
2012-04-19
2012-11-19
  • Zach
    Zach
    2012-04-19

    Ever since upgrading to 2.18 I can't get auto-type to work anymore.  I think the last version I had was 2.15 or something.   Anyway, the option just literally is greyed out on the context menu.  I haven't done anything different than I used to.  I checked in Tools -> Options -> Policy and and every single entry in the list is enabled.  I also checked the entries themselves in the database and Auto-Type is enabled for each of them as well.  But on every single one, when I right click the entry in the explorer, Perform Auto-Type is greyed out and unclickable.

    Am I missing something obvious here?

    Thanks

     
  • Zach
    Zach
    2012-04-19

    I also checked the entries themselves in the database and Auto-Type is enabled for each of them as well.

    Just to clarify, what I meant here is that for each entry I right clicked, hit Edit / View Entry, then went to Auto-Type and "Enable auto-type for this entry" is checked.

    I'm using Windows 7 x64, also.

     
  • wellread1
    wellread1
    2012-04-19

    Try copying the keepass.exe to your desktop and run it from there.  If it runs correctly from there you probably have something wrong with a plugin or a config file.  There are two types of config file, local user-dependent and forced.  Config files can be located is one of several places, see http://keepass.info/help/base/configuration.html

    -wellread1

     
  • Zach
    Zach
    2012-04-20

    Same thing when I run it from there.  It also happens on my work computer now after upgrading to 2.18.  Both are Windows 7 x64.

    I should point out that my home computer is on literally a barebones o/s install because I just reformatted yesterday and haven't installed anything else yet.  So it doesn't seem to be an issue with upgrading, it happens on fresh installs as well. 

    Given that it happens to me in 2 different configurations on a bare o/s install, I'm surprised I haven't seen this issue mentioned anywhere else, it almost seems like 100% repro.  But I don't know what else to try.

     
  • wellread1
    wellread1
    2012-04-20

    I have not observed the issue on Windows 7 Home x64.  The only situation in which I see the "Perform Auto-Type" greyed out on the context menu is when there is no entry selected.  I would have suggested that you test KeePass in safe mode but you indicate you have observed this on a clean install.  I am a afraid I haven't got any more suggestions.

    -wellread1

     
  • Dominik Reichl
    Dominik Reichl
    2012-04-20

    Also make sure that auto-type is enabled for the parent groups. Right-click the group -> 'Edit Group' -> tab 'Behavior'.

     
  • Paul
    Paul
    2012-04-20

    And check the policy.
    Tools > Options > Policy > Auto-Type.

    cheers, Paul

     
  • rracb
    rracb
    2012-04-23

    Confirmed.  Just installed 2.18 with Win 7/64 and auto-type doesn't work.  I've never used Keepass before but found this "bug" right off.

     
  • rracb
    rracb
    2012-04-24

    Beep.  Belay the previous comment.  Rebooted my Win 7/64 machine and presto, auto-type works fine now.