Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Limit to single instance preference not honored

Help
rimcaw
2014-03-18
2014-03-18
  • rimcaw
    rimcaw
    2014-03-18

    Hello,

    In keepass2 options->advanced, 'Limit to single instance' is checked
    but a new instance is created every time I launch keepass2.

    This problem does not happen in another user profile on the same machine (there, keepass2 is limited to a single instance).

    This is on ubuntu 13.10, with keepass2 2.25

    What might be wrong ?

     
  • Paul
    Paul
    2014-03-18

    As this works in Windows I suspect KeePass is not able to find instances running under Mono. I'm sure Dominik will confirm.

    cheers, Paul

     
  • rimcaw
    rimcaw
    2014-03-18

    I did not claim that it does not work at all.

    In one user profile, keepass2 is really limited to a single instance.

    In another one, it is not limited to a single instance, but it should be.
    And I am pretty sure that it was working in that profile not later than last week.

     
    Last edit: rimcaw 2014-03-18
  • Paul
    Paul
    2014-03-18

    Do you remember if anything changed in that profile recently?

    cheers, Paul

     
  • rimcaw
    rimcaw
    2014-03-18

    I don't remember, except for a permissions change (in particular, some files lost the executable permission).

     
  • Paul
    Paul
    2014-03-18

    Lack of executable may indeed be the issue. Are you able to compare permissions, or delete the profile and re-create?

    cheers, Paul

     
  • rimcaw
    rimcaw
    2014-03-18

    I may be able to compare with a backup or restore it.

    Files whose permissions were changed are in my HOME directory.

    What kind of files are you thinking about ?

     
  • Paul
    Paul
    2014-03-18

    Is KeePass installed in your home directory?

    cheers, Paul

     
  • rimcaw
    rimcaw
    2014-03-18

    No.
    It is installed once for all users from a package, files are below /usr.

     
  • Paul
    Paul
    2014-03-18

    Do you have a local keepass.config.xml and are the permissions OK?

    cheers, Paul

     
  • rimcaw
    rimcaw
    2014-03-18

    File ~/.config/KeePass/KeePass.config.xml is owned by me, mode is 644.

     
  • Paul
    Paul
    2014-03-18

    The only other thing I can think of is mono files / config files in your profile. Unfortunately I don't know what to look for.

    cheers, Paul

     
  • rimcaw
    rimcaw
    2014-03-18

    Thanks for your help.

    I went over some config files to do a few chmod 700 or 600.

    Single-instance is back !

    Auto-type with alt-F2 works again.
    But the hotkey is still broken.
    Maybe I need to fix some more permissions.

     
  • rimcaw
    rimcaw
    2014-03-18

    After logout/login the hotkey is back too.
    So all ends well.