Help Using Field References

Help
Eric
2011-04-08
2013-07-12
  • Eric
    Eric
    2011-04-08

    After reading the field reference documentation, and searching the forums, I am not sure that my Field references are working correctly.  I have an entry, A, who's password is more or less my master password.  I want another entry, B, to reference A's password.  In B's entry, I insert a field reference using Tools -> Insert Field Reference, selecting A's entry, and identifying it by UUID.  I then select Password.  Click OK.  Instead of having the password text show up in B's password field, it just shows the field reference string.  What am I doing wrong?  I would expect it to display the password from A's entry!

     
  • wellread1
    wellread1
    2011-04-08

    It's a bit geeky but that is the expected behavior.  Keepass will correctly dereference the field reference in an autotype sequence or if you copy the password (except from the Edit Entry dialog).

    -Wellread1

     
  • Eric
    Eric
    2011-04-08

    Thanks wellread!  Guess I gotta figure out how to use the Autotype stuff now.  Just been using KeePass as a simple password manager thus far.

     
  • wellread1
    wellread1
    2011-04-08

    Autotype is powerful and the default sequence works well with most sites out of the box.  Highly recommended. Or you can simply copy you password by double clicking on the password field in the main view.

    -Wellread1

     
  • Paul PS Sereno
    Paul PS Sereno
    2013-07-11

    Hello,

    I have the same "problem". Is there any way to make the entries real visible in the main view, so that not only the refernce string is visible?

    Best regards, Paul

     
  • wellread1
    wellread1
    2013-07-11

    Check Tools>Options.Interface(tab)>Entry List(section): "Show dereferenced data (slow)" to show the value in the View.

    Note: This option is available only in more recent versions of KeePass 2.x.

     
  • Paul PS Sereno
    Paul PS Sereno
    2013-07-12

    Thank you for that quick reply, that works great!