Keepass v2 no longer has -lock option, what's the alternative?

Help
Oon-Ee Ng
2014-03-20
2014-03-20
  • Oon-Ee Ng
    Oon-Ee Ng
    2014-03-20

    In order for --auto-type to work, Keepass must already be open. With keepassx and keepass v1, all we had to do was start it up when the computer boots with the -min and -lock parameters, it would be running in the background without any interaction with us.

    Now, starting with -min still asks for password, which I shouldn't need because I just want keepass running, not to access the passwords yet.

    How can I start keepass v2 up minimized without a password prompt so that I can use --auto-type without having to check (manually or in a script) whether there is a keepass instance open?

     
  • wellread1
    wellread1
    2014-03-20

    How can I start keepass v2 up minimized without a password prompt so that I can use --auto-type without having to check (manually or in a script) whether there is a keepass instance open?

    Check 'Start minimized and locked' in Tools>Options>Advanced(tab)>Start and Exit(section)
    To specify a database to open at startup either:

    • Check 'Remember and automatically open last used database at startup' or
    • Define a trigger to open a particular database at startup.
     
    Last edit: wellread1 2014-03-20
    • Oon-Ee Ng
      Oon-Ee Ng
      2014-03-20

      Thanks, that does it perfectly =)