2.0.6 - Entries Within Group Sorted Wrong

Help
Allan C.
2009-04-08
2014-07-12
1 2 > >> (Page 1 of 2)
  • Allan C.
    Allan C.
    2009-04-08

    I am using version 2.0.6 Beta and sorting a group by Notes in ascending order.
    Most of the time, new records appear out of order even after I sort them.
    Sometimes if I sort on another field and then sort on the notes field, the records appear in the correct sequence until I close and reopen KeePaas. Then they revert back to sorting correctly.

    Thank you in advance.

     
    • Paul
      Paul
      2009-04-08

      Please explain how you sort - exact keystrokes/mouse clicks?
      A screen shot or two would also help.

      cheers, Paul

       
      • Allan C.
        Allan C.
        2009-04-08

        These are my first postings at this site and I do not see how to add an attachment.

        I *think* that the symptoms may vary, however this scenario is current:
        1. I start KeePass 2.0.6. Beta.
        2. I choose the group that I want to display.
        3. An arrow pointing upwards appears beside the heading 'Notes'. The records are now sorted correctly *except* that the last record that I added is at the bottom of rows.
        4. I click on the columnar heading for 'user' (for example) and the records sort correctly.
        5. I click on the columnar heading for 'notes' and the records sort correctly.
        6. I exit KeePass
        7. Go to step 1.

         
        • appyface
          appyface
          2009-04-17

          I'm using 2.0.7 and have inconsistent sorting behavior on all columns.

          I have just one level of folders below the top level, no folders below that. 

          I have de-selected "show entries of subgroups" in the 'view' menu.

          Here's what happens for me in different sorting scenarios for Title bar.

          1.  Click on any folder.  All of the items in that folder now appear on the right. 

          2.  Click on Title bar to sort that column ascending.  A '^' character appears in the Title bar and the column is correctly sorted ascending by Title.

          3.  Click on any other folder, the contents are displayed on the right and are correctly sorted ascending by Title.

          4.  Click on Title bar again, the '^' inverts and the list is correctly sorted descending by Title.

          5.  Click on Title bar again, the inverted '^' character is gone, the list remains sorted descending by Title, and the 'show entries of subgroups' is now turned on (but is not shown as selected if you visit the View menu). 

          6.  Further clicking on the Title bar does not change the sorting at all, though in succession the '^', inverted '^' and then no sort indicator character, will appear in the title bar.

          7.  The only way I can restore functionality is to visit the View menu and select 'show entries of subgroups' (to turn it on even though it is already on, kind of), then de-select 'show entries of subgroups'.  Then return to step 1.

          Here's what happens for me in different sorting scenarios for sorting on Last Modification Time.

          Again note I prefer to have 'show entries in subgroups' disabled.

          1.  Click on any folder, contents of that folder appear on the right.

          2.  Click on 'last modification time' (a column in my view), the '^' indicator appears, and the list is sorted in ascending order by last modification time. 

          3.  Click again on 'last modification time', the inverted '^' indicator appears, the list is sorted in descending order by last modification time.

          4.  Click on any other folder.  The 'last modification time' column is about 80% correctly sorted.  The inverted '^' indicator is still shown. 

          5.  Click on 'last modification time' and again the partial 'show subgroups' view is turned on.

          6.  Just as for Title, nothing changes until 'show subgroups' option is visited on the view menu, enabled and then disabled.

          7.  THEN clicking on 'last modification time', twice, WILL sort the list correctly in descending order.

          8.  Click on another folder and the 'last modification time' column is again about 80% sorted correctly.

          I could go on but they are all variations on this same theme:  Sometimes the contents sort correctly, sometimes they don't, sometimes the partial 'show entries in subgroups' feature gets enabled and then sorting stops entirely until that feature is enabled fully then disabled.

          Hope this helps,
          --appyface

           
    • Paul
      Paul
      2009-04-09

      I can't reproduce this on V2.07. Please remove 2.06, install 2.07 and try again.

      cheers, Paul

       
    • Allan C.
      Allan C.
      2009-04-10

      You mean to literally uninstall 2.06 using the 'uninstall' in the program group, correct?
      Will my database be retained or do I have to export it?

       
    • Allan C.
      Allan C.
      2009-04-10

      You mean to literally uninstall 2.06 using the 'uninstall' in the program group, correct?
      Will my database be retained or do I have to export it?

       
    • Paul
      Paul
      2009-04-11

      Always backup your database regardless.

      Un-installing does not remove your database.

      cheers, Paul

       
    • Allan C.
      Allan C.
      2009-04-13

      The same symptoms continue with 2.07 Beta.

       
    • Paul
      Paul
      2009-04-13

      Can you create a new database and see if it happens there?

      cheers, Paul

       
      • Allan C.
        Allan C.
        2009-04-13

        After creating, did you want me to import the records from the older database or just add new records?

         
    • Paul
      Paul
      2009-04-14

      Both.  ;-))

      cheers, Paul

       
    • PQ T
      PQ T
      2009-04-15

      I've been dealing with the same problem.  I notice that the sort selection is applied universally for all groups.  So if you sort one group by user name and go to another group and sort it by URL, everything will be sorted by URL. 

      I believe version 1.xxx doesn't have this behavior.  Being able to sort different groups by different attributes is a nice features to have.

       
    • Allan C.
      Allan C.
      2009-04-15

      You are saying that your records in a group are not sorted as per the 'sort arrow' in the columnar heading?

       
    • PQ T
      PQ T
      2009-04-15

      They are sorted by the sort arrow.  However, in version 1.xxx key sort seems to be different per group.   On the 2.xxx version, if I choose to sort by URL, ALL groups are sorted by URL. 

       
    • Allan C.
      Allan C.
      2009-04-16

      The following are my notes:
      The existing database is named Keepass.
      When it is initially opened, the records appear to be mostly sorted correctly (in Notes order) but some of the records that start with 'B' or 'C' are incorrect.
      Specifically, five records start with 'B', 'C', 'B', 'B' and then 'C'.
      The first letter is upper case in all five examples.

      If I add a record that starts with a 'T' (for example), the records which were previously sorted incorrectly then sort correctly, and the 'T' record appears at the end in incorrect order (after a record that starts with 'W').
      If I close and reopen the database, the 'B' and 'C' records continue to be sorted correctly and the 'T' record is incorrect at the end.

      If I then delete the 'T' record at the end, the five records revert back to their incorrect order.

      I created a new database, exported from the original and imported to the new.
      The symptoms were *exactly* the same when duplicating the test.

      I hope this helps.

       
    • Paul
      Paul
      2009-04-17

      appyface, this is a bug in Windows XP.

      Allan C, I get similar behaviour if I sort by Notes. Sorting by Title seems to be OK.

      cheers, Paul

       
      • appyface
        appyface
        2009-04-18

        Hi Paul,

        Would you please elaborate on this 'bug' in XP?  What it is, where it is?  I run lots of .net apps in XP and haven't seen this before.  So I'd like to understand the issue better since other apps ought to experience it sooner or later?

        Regardless, can Keepass work around it so we don't have this odd 'feature'(LOL)?

        Thanks for help/info,
        --appyface

         
        • Dominik Reichl
          Dominik Reichl
          2009-04-18

          • appyface
            appyface
            2009-05-06

            Thank you for the link, Dominik, I read the report and comments, but I'm not sure what it means.  Does it mean it is still an open issue to be fixed but the cause remains unclear (impossible to fix if cause is unknown)? Sorry I'm n00b, TIA --appyface

             
            • Paul
              Paul
              2009-05-06

              It means there is no fix because the cause cannot be found.

              cheers, Paul

               
    • Allan C.
      Allan C.
      2009-04-17

      That is good to hear.
      A bug that can be duplicated at any time is easier to fix :).

       
    • Allan C.
      Allan C.
      2009-04-18

      I think I have a workaround for sorting by Notes being incorrect.

      1. After you have added a record and the sort order is incorrect - Add a fake placeholder record with a Note of 'ZZZZZZZZZZZZZZZZZZZZZZZZZZZ'.
      The records will sort properly.
      2. Next time that you want to add a record, delete the 'ZZZZ' record above.
      Add your real record.
      Records sort improperly - Go to step 1.

      Not eloquent, but I think that it works.

      Comments?

       
    • Paul
      Paul
      2009-04-19

      Allan, please report this as a bug.
      https://sourceforge.net/tracker/?group_id=95013&atid=609908

      cheers, Paul

       
    • Dominik Reichl
      Dominik Reichl
      2009-04-22

      Allan, thanks a lot for reporting this problem! I've fixed it; subitem sorting will work correctly in the next version.

      Here's the latest 2.x development snapshot for testing (only!):
      http://keepass.info/filepool/KeePass_090422.zip

      Best regards
      Dominik

       
1 2 > >> (Page 1 of 2)