Keepass with Youbikey neo fails to work after some (unspecified) number of uses

Help
gmc1770
2013-09-06
2014-01-08
  • gmc1770
    gmc1770
    2013-09-06

    This is an unusual one.
    I have a Yubikey Neo and have set it up to use KeePass with OtpKeyProv.plgx
    I setup the Yubikey for OATH-HOTP
    It works fine for a while then eventually fails, (1, 5, 10 times.. random) on a new key insert, (error below).

    KeePass
    Failed to create OTP key!
    Make sure you've entered the correct OTP's.
    If you continue to have problems, Switch to recovery mode' tab and provide the OTP generator tokens secret key.

    In all cases, I can enter the secret key and no issues.. I get in..
    but there is no way I can get in with the yubikey anymore with the OATH-HOTP function.

    I have tested..(after failure)
    cannot use a backup copy of the file, does not work.
    can re-program everything and it will work again. for a time.

    Any thoughts?

     
    Last edit: gmc1770 2013-09-06
  • Paul
    Paul
    2013-09-06

    Sounds like the Yubikey and KeePass are getting out of sync. Do you use the Yubikey for anything else, or are you generating keys by accident?

    cheers, Paul

     
  • klabog
    klabog
    2014-01-02

    Hi, I have the same problem as gmc7070.
    Configured yubikey and it worked with a newly created keepass2 db perfectly.
    I did some tests with no problems. Then I changed the options to auto tab and auto confirm and confirmed without putting in the OTPs by error. From now on I was unable to access the db with OTP. Only get access with secret key.
    No way to resync keepass with yubikey.
    I thought resync is performed when you successfully enter keepass? Seems that this only works when you access with OTP not accessing with secret key.
    Any ideas? Any other way to resync?

    Regards, Klaus

     
  • Paul
    Paul
    2014-01-02

    You can resync if you know what number Yubikey is up to, but that is unlikely. You should re-create the sync using your original secret key.

    cheers, Paul

     
  • klabog
    klabog
    2014-01-03

    Paul, that's what I tried to do. When I have logged in with my secret key I have to do anything more to sync? If not then it doesn't work because I still get the same error.
    Thanks for your answer.
    Regards, Klaus

     
  • Paul
    Paul
    2014-01-03

    My understanding is you need to re-create the sync from scratch. Once you log in with the secret key the sync goes out the window, unless you have a longish look ahead buffer, but if the reason you used the secret is lack of sync then it's start again.

    cheers, Paul

     
  • klabog
    klabog
    2014-01-04

    Sorry, how do I re-create sync from scratch? What I noticed too is that in my Ubuntu 12.04 I do not have the toolbar as in Windows (File, Edit, View, Tools). Is there a way to get it visible in Linux?
    Regards, Klaus

     
    Last edit: klabog 2014-01-04
  • Paul
    Paul
    2014-01-04

    Follow the instructions in OtpKeyProv_ReadMe.html.
    If you can't see the menu to do this, press Alt F, D.

    cheers, Paul

     
  • klabog
    klabog
    2014-01-04

    Thanks Paul. In my Ubuntu 12.04 there is no way to get the toolbar. ALT F, D does nothing at all. I had to get a Window notebook to try to fix it but something went wrong and I began from scratch with a new dbase.
    I have one more question. When I go to change master key and then to the options of OTP in keepass2 there is a counter. Have I to set it to 0 to get resync? It seems that I former didn't put in the look forward value and it stayed in default value 0.
    Regards, Klaus

     
  • klabog
    klabog
    2014-01-05

    I will try this after another failed sync. I'm wondering if the lost toolbar in Ubuntu 12.04 is a bug or if I still didn't discover the trick.
    Regards, Klaus

     
  • Paul
    Paul
    2014-01-05

    Mono is responsible for drawing the screen image so the missing toolbar is likely to be a mono issue.

    cheers, Paul

     
  • klabog
    klabog
    2014-01-05

    I had some components of Mono installed and because of your comment I installed mono-complete but still don't get any toolbar. Only thing which changed is that I now can call all menu options with CTRL- or ALT-. By the way ALT-F gives find, no chance to introduce D.
    Still thinking that there is a bug.
    Regards, Klaus

     
  • Paul
    Paul
    2014-01-06

    Ctrl F is the Find shortcut. Alt F opens the File menu.

    It's still not a KeePass bug, it works correctly in Windows.

    cheers, Paul

     
  • klabog
    klabog
    2014-01-06

    Sorry, but here ALT-F does the same as CTRL-F and this is find (with all menu options ALT- and CTRL- are identical). Tried many other combinations but no chance. I'm stuck.
    I think I should open another thread with this issue to involve anyone who has this same problem.
    And yes your are right: It works in Windows

    Regards, Klaus

     
    Last edit: klabog 2014-01-06
  • klabog
    klabog
    2014-01-06

    KeePass2 isn't in the official ubuntu packages (precise). Therefore I used an inofficial one: LP-PPA-blueeyed/precise for KeePass itself and LP-PPA-dlech-keepass2-plugins/precise for some plugins.
    Any better idea?
    Just noticed that in KeePassX which is in the packages I don't get a toolbar too.
    Regards, Klaus

     
    Last edit: klabog 2014-01-06
  • Paul
    Paul
    2014-01-07

    I would try the one in the link I gave you.

    cheers, Paul

     
  • klabog
    klabog
    2014-01-07

    Changed the packages, updated and get the same issue.
    I remember a problem with another software some years ago with invisible tool-tips which had his reason in the Compiz configuration which I solved with the CompizConfiguration-Manager. It was not my idea but a hint from the WEB. The problem is that there are hundreds of options and I'm unable to imagine what could be the problem with the toolbar.
    Are you able to give me hints or can get me in touch with anyone who could give me help?
    Thanks, Klaus

     
  • Paul
    Paul
    2014-01-08

    I'm out of ideas. Why don't you ask on the mono forum.

    cheers, Paul