Save kdbx on Seafile Server with webDAV (400 Bad Request)

Help
Gigglo
2014-05-29
2014-06-04
  • Gigglo
    Gigglo
    2014-05-29

    Hi,

    I run a Seafile server (similar to Owncloud) to have access to the kbdx-file from different devices. Created a test file, saved it locally on my laptop and uploaded it with webDAV to the Seafile Server. That works without any issues.

    Then I opened the kdbx-file from the Seafile server (https!) on different devices: Linux Mint with Keepass 2.24, Windows 7 with Keepass 2.26 and an Android Kitkat Smartphone with Keepass2Android 0.9.3-r5. Opening works also without any issues.

    But I can't save any changes from Keepass to the Seafile server. I doensn't work from any of the 3 devices. I always get an error message like: "Failed to save the current database to the specitic location! The remote server returned an error: (400) Bad Request. The target file might be corrupted. Please try saving again...".

    First I thought it was a permission issue. So tested it with a libereoffice file. So, there are no problems with saving changed files on my Seafile-Server.

    What do I have to do, to change the edited kbdx-file on the Seafile server? Is there a way to log with keepass?

    Thanks and regards

    gigglo

     
    Last edit: Gigglo 2014-05-29
  • Paul
    Paul
    2014-05-29

    KeePass uses file transactions to write the database so you need create, delete, and rename permissions. You could try turning off File Transactions to test. (Tools > Options > Advanced, File input/Output)
    If you want a log you'll need to get it from your server, KeePass doesn't log file write transactions.

    cheers, Paul

     
  • Gigglo
    Gigglo
    2014-06-03

    Hi Paul,

    thanks for your answer. Now I know that this issue doesn't have to to with Keepass. The problem is that the Seafile Server doesn't allow to create tmp-files on it. Please have a look in here: https://github.com/haiwen/seahub/issues/214

    Regards, Gigglo

     
  • Paul
    Paul
    2014-06-04

    Ouch!

    cheers, Paul