KeePass 2 triggers under Linux?

  • I am running Fedora 17, and decided to try using KeePass to store and generate my passwords.   In an ideal world I would want to use KeePass 1, since that is the only version supported Read/Write for android.   But I noticed there is no KeeFox plugin for KeePass 1.  Since I consider Firefox integration a requirement I went with KeePass 2.   The problem I'm running into is the triggers do not actually seem to be fireing.

    I tried both a syncronization trigger and a save trigger to save a copy of my keypass database to saved disk whenever, I save an update to my database.   The problem is I found first of all the database is never created on the saved disk.   I manually copied it there, thinking maybe then it could update.   However, I see by the time stamp and file size the file is never being updated.   I'm wondering if I am doing something wrong, or if the triggers are broken.

    One of the pecularities I notice is there is no File/URL field for the actions.   There is a blank field however, and it seems to accept a filename there…

    What is the method I should used to debug what is happening with the triggers?



  • It seems part of the problem is the trigger changes I was making were not being saved.   I finally got them to save, and now on database open and database close, I can synchronize.   I also tried to do a trigger on database save, but it just goes into an endless loop.   It looks like KeePass 2.x running under mono cannot export or synchronize with the KeePass 1.x database format.  So I will still need to work on finding a way of synchronizing with Android, which can only write to KeePass 1.x database format.   It might be possible, to import and export to xml, but that would mean exposing my passwords…


  • wellread1

    A sync initiates a save, so using a save to trigger a sync will result in an endless loop unless the trigger is temporarily disabled prior to the sync action.  See for an example of how to write a trigger to avoid an infinite loop.


  • I see.  Thanks.