TCATO + layouts control

NiceName
2014-07-01
2014-07-02
  • NiceName
    NiceName
    2014-07-01

    Hi,
    I use Auto-Type all time. And there is the great "ensure same keyboard layouts during auto-type" option. It's very useful. But this option doesn't work right with TCATO. Is it a "bug"? Or I do something wrong?
    Thank.
    p/s/ KeePass 2.26 + Windows7

     
    Last edit: NiceName 2014-07-01
  • Paul
    Paul
    2014-07-01

    What keyboard layout do you use?
    What doesn't work? Can you use a test entry with a known pattern and tell us what happens?
    e.g. Username: abcdefghijklm
    Password: 12345678901234567890
    Use the test page for your testing.
    http://keepass.info/help/kb/testform.html

    cheers, Paul

     
    Last edit: Paul 2014-07-01
  • NiceName
    NiceName
    2014-07-01

    Ok. Lets try.
    I use Russian (RU) and English (EN) layout.
    Two diferent window(application) may have diferent layout in the same moment. When I'm using the Auto-Type without TCATO I don't have problem with diferent layout on the KeePass and a target window, at all. Any combination of layouts is working perfect.
    But it's not the same when TCATO is on. It's work fine when the target window have EN layout only. And I have only a half when the target window have RU layout. No matter what layout on keepass.
    Sorry. English is not easy for me.
    Let me give you some results of my test with your test entry:
    I used KeePass and Windows Notepad. Keepass may have EN or RU layout. NotePad may have EN or RU layout too. TCATO is on.
    1. KeePass (EN) --> Notepad (EN) = abcdefghijklm 12345678901234567890
    2. KeePass (RU) --> Notepad (EN) = abcdefghijklm 12345678901234567890
    3. KeePass (RU) --> Notepad (RU) = 12abv6e8gijm3 v790
    4. KeePass (EN) --> Notepad (RU) = 12abv6e8gijm3 v790

    I used KeePass and the test page http://keepass.info/help/kb/testform.html
    1. KeePass (EN) --> test page (EN) = abcdefghijklm 12345678901234567890
    2. KeePass (RU) --> test page (EN) = abcdefghijklm 12345678901234567890
    3. KeePass (RU) --> test page (RU) = abvegijm 12v683790
    4. KeePass (EN) --> test page (RU) = abvegijm 12v683790

    Pattern is {USERNAME}{TAB}{PASSWORD}
    I hope you'll understand my english writing. :)

     
    Last edit: NiceName 2014-07-01
  • Dominik Reichl
    Dominik Reichl
    2014-07-02

    Thanks for reporting this issue! I was able to reproduce it. It has to do with the difference between 'v' and 'м' on Russian keyboards. I've now changed the way how the 'v' keypress is sent, and with this at least on my testing system it now also works with the Russian keyboard layout.

    Here's the latest development snapshot for testing:
    http://keepass.info/filepool/KeePass_140702.zip

    Best regards,
    Dominik

     
  • NiceName
    NiceName
    2014-07-02

    Thanks. I made some quick tests with the development snapshot that you gave me. It seems like it works fine on my system too.
    P.S. Maybe one more note about layouts. I can't see what kind layout is active when I do enter my master key on secure desktop. There is no any marks. My usual desktop marks is disable at this time. Like you may see on the screenshot Windows UAC shows the language panel in this case.
    But anyway Thank you for KeePass.