Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

How to generate a password for an existing entry

upor
2014-04-14
2014-04-28
  • upor
    upor
    2014-04-14

    How do I generate a password using KeePass, so that I can replace an existing password with a new password?

    When I click Tools > Generate Password, I get a new entry. That's not what I want. I want to edit a current entry and generate a new password.

    Using KeePass 2.26

    Thanks

     
  • totya7
    totya7
    2014-04-14

    open entry where u want new password
    repeat field - right side - see icon - generate a password

     
  • upor
    upor
    2014-04-15

    Thanks, that worked.

     
  • Trent
    Trent
    2014-04-19

    This doesn't work for me. It USED to work, but no longer does, clicking Generate a Password has no effect. It doesn't change the password and it doesn't give me the menu to access the password generation profiles. Any ideas what to do? I already tried uninstalling and reinstalling.
    Windows 7 Ultimate, KeePass 2.26

    I should flesh out what happened. I was going through manually entering passwords I had stored in an unsecure text document. I planned to enter them and then go back and create new passwords with KeePass. I entered quite a few maybe 20-30, I replaced a few of them early in the process and it worked just fine. Later I tried replacing another one and found I couldn't. Passwords are still being generated when the new entry is created, but I can't generate a new one as described above.

     
    Last edit: Trent 2014-04-19
  • Paul
    Paul
    2014-04-19

    Clicking "Generate a password" should bring up a menu which includes "Open Password Generator". Can you also try opening the password generator from the main menu, Tools > Generate Password.

    cheers, Paul

     
  • Trent
    Trent
    2014-04-19

    Hello Paul,

    Thanks for the reply.
    Clicking "Generate a Password" does nothing except make the icon blink. It worked when I first installed the program, but now doesn't.
    Tools > Generate Password works just fine.
    This wouldn't be that big a deal except the passwords that are being created aren't suitable for every password I have, and I have a quite a few. It would take quite awhile to make entries with Tools > Generate Password so I'm hoping to avoid that. I've entered quite a few already that really aren't very good passwords and need replaced. I'm also curious what broke.

     
  • Paul
    Paul
    2014-04-19

    Have you updated Windows or .NET recently? KeePass uses .NET to draw the screen so it may be fixable by repairing the .NET installation.

    cheers, Paul

     
  • Trent
    Trent
    2014-04-20

    No I haven't.

    I tried creating a new database and had the same problem. That being the case I ruled out a problem with the database itself, so I simply renamed the config and .ini files in Appdata > Roaming. Apparently something got corrupted or perhaps I somehow changed an obscure setting and didn't realize it. That fixed the problem. I had to recreate my custom password generator (no surprise there since the settings were effectively gone) and it's working as expected.

    I have quite a few more passwords to enter, I'll see if I can recreate or observe this behavior again. I will post the cause if I can determine it.

    Thanks for your help.

     
  • Dominik Reichl
    Dominik Reichl
    2014-04-20

    Can you please post your configuration file (the one that you renamed)? Maybe I can reproduce your issue with it.

    Best regards,
    Dominik

     
  • Trent
    Trent
    2014-04-21

    Hi Dominik,

    First off thanks for a great product, I should have started using it YEARS ago. I'm really pleased with it in spite of this small problem I had.

    I'll be happy to do that. There's an .xml and .ini, what do you need exactly? What should I do, attach it here? I can dropbox it or something if necessary. Do I need to worry about cleaning up personal information in the file?

     
  • Paul
    Paul
    2014-04-21

    Both the INI and XML files from Appdata > Roaming. You can edit them in Notepad, then click on the "add attachments" button next to the Post button.

    cheers, Paul

     
  • Trent
    Trent
    2014-04-22

    Thanks. Sanitized versions of each are attached. Edits appear as xxxxxx, and I changed the name of the affected database to password.

     
  • Dominik Reichl
    Dominik Reichl
    2014-04-23

    Thanks. Unfortunately, even with your configuration file, I still cannot reproduce the issue; the popup menu works perfectly fine for me.

    Do you have any other input-related software installed? I observed that when holding down the Alt key while clicking the password generator button prevents the popup menu from being displayed (which seems to be a Windows feature though; even Notepad behaves like this).

    Best regards,
    Dominik

     
  • Trent
    Trent
    2014-04-28

    No I don't. The only thing I can think of is I have a security product called Webroot running. It has a feature called Identity Protection which is supposed to protect certain applications from keyloggers. It's mainly designed for web browsers but any application can be added. Webroot added KeePass to its list of identity protected apps automatically. I've noticed occasional erratic behavior related to this in other programs so maybe that's what happened. I removed KeePass from the list and haven't had anymore problems. It's a bit odd though, everything worked just fine for awhile and then something seemed to break at random.

    Thanks again everyone for your help.