Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

WordSequence plugin

fireOut
2012-01-17
2012-11-20
  • fireOut
    fireOut
    2012-01-17

    I've created a password generator that generates word list password instead of character password.

    https://sourceforge.net/projects/kpwordsequence/

    I've done minor testing but I'm using it myself for some of my passwords, documentation might need to be added, anyone wanting to help is more than welcome.

    fireOut

    ps:This is my first sf project, so please tell me if i'm doing anything wrong

     
  • Dominik Reichl
    Dominik Reichl
    2012-01-18

    Nice plugin, thanks!

    I've added it to the KeePass plugins page: http://keepass.info/plugins.html

    Best regards
    Dominik

     
  • develop1
    develop1
    2012-01-21

    FYI  This pc is currently v2.15
    I did the following:
    - exited keepass app
    - downloaded pluggin
    - copied the two "wordsequence" files - a config and dll to the keepass folder
    launched the keepass app.
    I immediately get the following dialog box (text below)
    the keepass app proceeds to run but without the pluggin of couse.
    I suppose it might work in a more current 2.x release and its probably not a bad thing for me to update/upgrade to a more current release.
    but I thought I should notify someone that if its supposed to work with 2.x it does not work with 2.15
    ===================================================


    KeePass

    The following plugin is incompatible with the current KeePass version:

    C:\Program Files\KeePass Password Safe 2\WordSequence.dll

    Have a look at the plugin's website for an appropriate version.

    OK  

     
  • fireOut
    fireOut
    2012-01-23

    Thank you develop1,

    I updated my project desc to indicate it's only compatible with 2.18.

    I'll update it again once updated.

    fireOut

     
  • William Thomas
    William Thomas
    2012-02-22

    I am unable to use the plugin with KeePass 2.18.  When I start KeePass I get:
    "The following plugin is incompatible with the current KeePass version:…."

    Not sure why, possibly because I am running a 64bit OS?

     
  • fireOut
    fireOut
    2012-02-22

    I'm using Windows 7 64 bit myself and it works fine.

    You might need .NET Framework 3.5 installed.  I never really tried on a machine that doesn't have it installed so I'm not sure about the message you would receive…

    It is possible for you to install .NET Framework 3.5?

    Please confirm so I can update the requirements.

     
  • William Thomas
    William Thomas
    2012-02-23

    Do you mean 3.5 or 3.5.1?  I have 3.5.1 installed (along with the HTTP components) from Add Windows Features.  Still no go on your extension though.

     
  • fireOut
    fireOut
    2012-02-24

    3.5 should be enough, in fact, i'm only using assemblies from version 2.0.

    I couldn't find how to retrieve logs to help debug…

    Do you have any other info that can help find the problem?

     
  • Dominik Reichl
    Dominik Reichl
    2012-02-24

    I'd suggest running KeePass.exe with the "-debug" command line switch. It then shows a more detailed error message.

    Best regards
    Dominik