Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Endless logon with new GMAIL URL?

Joe Banks
2013-11-12
2013-11-13
  • Joe Banks
    Joe Banks
    2013-11-12

    I'm running the latest version of KP on a Windows 7 system, and everything works fine, except for whatever recent changes "The Google" did to their GMAIL sign-on screens. Now, instead of exiting cleanly when I sign out of GMAIL, Keepass logs me back in again.

    I know that it is KP doing this, as it works fine when I close that program first.

    What's bothering me most is that I turned off auto-type for my GMAIL entry, and rebooted my machine.

    The old URL used to be "HTTPS://mail.google.com". Now, GMAIL is adding all types of passed switches and links. So far, I can't find documentation for those.

    I suspect it is part of Google's "Keep me logged in" cookies, but I can't be sure. And yes, I've de-selected the "Keep me logged in" box when I sign in to GMAIL.

    Suggestions are most welcome!

    -mvs

     
  • wellread1
    wellread1
    2013-11-12

    Default KeePass can not logon to any web page without first receiving an explicit user command e.g. the user presses a global hot key to initiate auto-type. However a form-filling plugin might cause the behavior you describe. First identify the form filling plugin that you are using. The plugin may have a forum where you can get help.

     
    Last edit: wellread1 2013-11-12
  • Joe Banks
    Joe Banks
    2013-11-13

    Thanks, wellread1, you solved my problem.

    I'm using the KeeFox plugin, and the option for "Submit form when there are multiple matches" was still checked off. Clearing that option fixed this issue.

    Thanks again, and long live open source!