Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

TABing works - just not in auto-tyoe

DrDOS
2012-10-27
2012-11-20
  • DrDOS
    DrDOS
    2012-10-27

    Hello,

    I can Tab to the password field when I am on the site but not when using LCtl-LAlt-A.  My coding {HOME}+{END}{USERNAME}{TAB}{HOME}+{END}{PASSWORD}{ENTER} has worked fine for quite a while.  It worked fine yesterday.  Same results on test site http://keepass.info/help/kb/testform.html.  Puts both in Username field.  What can I check?

    Thanks

     
  • Paul
    Paul
    2012-10-28

    Change back to the default Auto-Type routine and test.
    Change {HOME}+{END} to ^a
    Add a delay to the beginning, {DELAY=50}

    cheers, Paul

     
  • DrDOS
    DrDOS
    2012-10-29

    Paul

    Works the same.  I changed for that one site, not globally.
    OLD
    {HOME}+{END}{USERNAME}{TAB}{HOME}+{END}{PASSWORD}{ENTER}
    NEW
    {DELAY=50}^a{USERNAME}{TAB}^a{PASSWORD}

    The instruction to TAB is ignored.  All is typed in the User Name.

    I can press the Tab key on the page http://keepass.info/help/kb/testform.html and it works fine.

    What I also tried
    Added two {TAB} commands where there was 1
    Removed any cached entries
    User name = Tester
    Password = TesterPwd

    Thanks.

     
  • Paul
    Paul
    2012-10-31

    Have you loaded any new software?
    Patched Windows?
    Have you tried a different browser?

    cheers, Paul

     
  • DrDOS
    DrDOS
    2012-10-31

    Paul,

    Safe Mode w/networking works fine except for Keepass test page and Norton password; same as before.

    But I can fill in puzzle. :)  http://www.arcamax.com/games/crossword/s-1223378

    Have you loaded any new software? (see below) (I think it started begin of month)

    1. 12:09 AM 9/7/2012.NET Framework v4.5

    2. 11:13 AM 9/8/2012;Installing Smileycons v6.0.1

    3. 9:40 AM 9/9/2012;Installing Ultra Defragmenter v5.0.7 (386)

    4. 10:23 AM 9/9/2012;Updating Keepass to v2.20

    5. 11:21 AM 9/10/2012;Installing update to Foxit Reader

    6. 6:49 AM 9/11/2012;Installing RegAlyzer v1.6.2.16

    7. 2:29 PM 9/11/2012;Installed EMDB update v1.57

    8. 4:49 AM 9/12/2012;Installed EMDB update v1.58

    9. 3:42 AM 9/14/2012;Installing AnVir Task Manager

    10. 8:51 AM 9/14/2012;Installed GhostKey & IE Plugin

    11. 5:27 PM 9/14/2012;Installing MS Visual Basic 2010 Express (for .NET)

    12. 5:32 PM 9/14/2012;Installing MS SQL Server 2008 Express SP1

    13. 7:07 PM 9/14/2012;Uninstalling MS Visual C++ 2005

    14. 7:58 AM 9/18/2012;Removed GhostKey & IE Plugin - was keeping me out Gmail

    15. 4:31 PM 9/25/2012;Installing update CCleaner v3.23

    16. 9:37 AM 9/26/2012;Installing ENHANCED MITIGATION EXPERIENCE TOOLKIT (EMET)

    17. 7:28 AM 10/1/2012;Installing FormatFactory v2.96

    18. 8:33 AM 10/1/2012;Installing AutoScreenRecorder v3.1.125

    19. 11:50 AM 10/1/2012;Updated geek to v1.0.4.7

    20. 11:52 AM 10/1/2012;Removing Wisdom-soft toolbar - came with AutoScreenRecorder

    21. 1:23 PM 10/1/2012;Installing DVD Shrink v3.2

    22. 2:14 PM 10/1/2012;Installing HandBrake v0.9.8

    23. 7:30 AM 10/2/2012;Removing FormatFactory - doesn't seem to work

    24. 4:03 PM 10/2/2012;Uninstalled GrepWin

    25. 4:28 PM 10/2/2012;Reinstalling MPC-HC v1.6.4.6052 from Sourceforge

    26. 5:38 PM 10/2/2012;Installed GrepWin v1.5.9

    27. 9:59 AM 10/3/2012;Installing K-Lite Codec Pack 9.3.0 (Full) which removed MPC-HC v1.6.4.6052

    28. 10:19 AM 10/3/2012;Applied KL CP Update v9.3.2 (2012-10-02)

    29. 2:50 AM 10/5/2012;Update Keepass v2.20.1

    30. 9:03 AM 10/5/2012;Installing Constant Guard from Xfinity

    31. 5:21 PM 10/5/2012;Uninstalling HandBrake - doesn't seem to work

    32. 5:30 PM 10/5/2012;Panda Active Scan - all ok

    33. 5:32 PM 10/5/2012;Uninstalling Agent Ransack 2010 - never used

    34. 6:15 PM 10/5/2012;Uninstalling CleanMem

    35. 6:25 PM 10/5/2012;Uninstalling DVDShrink - doesn't seem to work

    36. 6:28 PM 10/5/2012;Uninstalling Image to OCR Converter - only used for Dave

    37. 6:31 PM 10/5/2012;Uninstalling ManicTime - never used much

    38. 6:36 PM 10/5/2012;Uninstalling MyTomTom - for Dave

    39. 6:40 PM 10/5/2012;Uninstalling OurSecret - didn't use much

    40. 6:45 PM 10/5/2012;Uninstalling Patchbeam - not sure where I got this

    41. 6:47 PM 10/5/2012;Uninstalling RegCure

    42. 6:49 PM 10/5/2012;Uninstalling Temp File Cleaner

    43. 6:59 PM 10/5/2012;Uninstalling Wondershare PDF Converter - only used for Dave

    44. 9:49 PM 10/5/2012;Installing update for Auslogics Duplicate File Finder v2.4.0.10

    45. 9:55 PM 10/5/2012;Installing Duplicate Cleaner Pro v3.0.9

    46. 1:07 PM 10/19/2012;Installed MozBackup v1.5.1

    47. 4:24 PM 10/19/2012;Installed FireFox to replace IE9

    48. 2:41 PM 10/25/2012;Installing update to Adobe Shockwave Player (NPAPI) v11.6.7.637

    49. 2:45 PM 10/25/2012;Installing update to CCleaner v3.24.1850

    50. 10:16 PM 10/25/2012;Uninstalled PhraseExpress v8.0.154

    51. 10:42 PM 10/25/2012;Installing PhraseExpress v8.0.154

    52. 9:23 AM 10/26/2012;Installing Cookie Editor v1.9.1.469

    53. 11:54 AM 10/26/2012;Installing PhraseExpress v9.0.128p - Demo Beta

    54. 1:56 PM 10/27/2012;Installed BoostSpeed v5.4

    55. 2:04 PM 10/27/2012;Uninstalled same - not free

    56. 9:21 PM 10/27/2012;Updating TeamViewer 7 from 7.0.14563 to v7.0.15723

    57. 11:33 AM 10/29/2012;Installing Registrar Registry Manager v7.50 32-bit Home Edition

    58. 12:30 PM 10/29/2012;trying to troubleshoot why interactive crossword no longer works - been that way a few weeks now

    59. 12:40 PM 10/29/2012;Uninstalling all Adobe products and Java - no change

    60. 12:47 PM 10/29/2012;Uninstalling all EMET Notifier

    61. 12:51 PM 10/29/2012;Uninstalling .NET apps

    62. 1:11 PM 10/29/2012;Uninstalling MS SQL

    63. 1:19 PM 10/29/2012;Uninstalling Visual Basic

    64. 1:23 PM 10/29/2012;Uninstalling Visual C++

    65. 1:25 PM 10/29/2012;Uninstalling Visual Studio

    66. 1:42 PM 10/29/2012;Uninstalling Keyrocket by Veodin

    67. 1:44 PM 10/29/2012;Uninstalling WinPatrol

    68. 2:07 PM 10/29/2012;Installing .NET 3.5 SP1

    69. 2:17 PM 10/29/2012;Installing updates from MS - .NET

    70. 2:44 PM 10/29/2012;Installing .NET Framework 4 Client Profile

    71. 3:05 PM 10/29/2012;Installing updates for .NET Framework 4

    72. 4:44 PM 10/29/2012;Installing Java SE 7 Update 09

    73. 4:59 PM 10/29/2012;Installing Adobe Shockwave Player v11.6.8.638

    74. 5:05 PM 10/29/2012;Installing Adobe Air v3.4

    75. 5:17 PM 10/29/2012;Changing Virtual Memory from 3072/3072 to auto

    Patched Windows? Probably - as needed/not auto

    Have you tried a different browser? FireFox - latest version - it seems to be browser-related but KeePass test page still doesn't work

    I "could" reload but was hoping not to do that.  Ugh!

     
  • Paul
    Paul
    2012-11-01

    Nothing obvious, but it could be anything that changes the keyboard handler.
    Try an Auto-Type into Notepad to eliminate the browser issue.

    cheers, Paul

     
  • DrDOS
    DrDOS
    2012-11-03

    Paul,

    Good call.  Not a browser issue.

    After reading , here's my results.

    TestingPassword

    is what is displayed

    I figure it should be

    Testing TestingPassword (figure the space was caused by Tab)

    Oh.  Arcamax site I mentioned previously now works!

    Again, on your test site I can Tab as needed.

    So what can change the keyboard handler or do you have something else I can try?

    One thing I haven't tried is reinstalling Keepass.

    Thanks.

     
  • Paul
    Paul
    2012-11-03

    KeePass uses .NET calls to send keystrokes to programs. If .NET is playing up that can cause problems.
    To test this load the ZIP version of KeePass V1 and try an Auto-Type - V1 does not use .NET.
    If this works you could try the RDCAutoType plug-in.

    cheers, Paul

     
  • DrDOS
    DrDOS
    2012-11-03

    Paul,

    Results with KP V1
    TestingTestingPassword

    Interesting.  I removed and reinstalled .NET (through updates), wondering if it could be the culprit.

    I assume the link you sent me is for 2.20.1.  I'll look into this next.  If this fixes, cool.  If not, how (if you know) do I let Microsoft know?

    Thanks!

     
  • DrDOS
    DrDOS
    2012-11-03

    Paul,

    Same as before in Notepad
    TestingPassword

    Do I need to complain to Microsoft (somehow)?

    Thanks for all your help too.

     
  • Paul
    Paul
    2012-11-04

    Did it work with V1? I can't tell from your post.

    I doubt MS will be interested in our little problem. It also doesn't help that it works for most people, just not for you.

    cheers, Paul

     
  • DrDOS
    DrDOS
    2012-11-04

    Paul,

    V1 worked in Notepad.  Still not on websites.  Sorry my reading didn't point out that troubleshooting process earlier.

    HOLD THE PRESSES!

    I feel I'm onto something.  Been using PhraseExpress for a while now.  Went from v8 to v9Beta (a few weeks ago) and "thought" I was ok.  I will let them know the issues I've had.  (Grrr)

    Remove PE and both 2.20 and V1 of Keepass work fine.  Add it back in, 2 and V1 don't work in web browser but V1 works in Notepad.

    Arcamax site working again too.  :-)

    Thanks again Paul for your help and patience with me working through all this confusion.  I will try to Pay It Forward.

     
  • DrDOS
    DrDOS
    2012-11-06

    Paul,

    Thanks.  Seem to be all better now.  When you said "keyboard handler", it didn't dawn on me to look at the one program I have that I use to help me do that.  Geesh!!  I've been using it for a few months and KeePass much longer.  I guess the Beta version I tried was configured in a way that "broke" my old standby.

    Appreciate all your help and patience with me.

    Have a good day!!