introducing debian/ubuntu keepass2 package

2011-04-25
2014-11-06
<< < 1 2 3 (Page 3 of 3)
  • BWMerlin
    BWMerlin
    2012-10-13

    Please ignore my above post (can't find the delete or edit option) but I have fixed my problem (I did not download the required .dll files correctly and that is why they were not showing up in keepass) and everything is now working correctly.

     
  • Scott
    Scott
    2013-03-02

    @Julian - I'm a newb using Ubuntu and I see the package is stuck on 2.19. I'm assuming that your efforts are key to releases for Ubuntu. Is there anything we can do to help get the project caught up to 2.21? I see note of xsel to improve clipboard handling. Is this package so different that is failed to get past experimental, or did you just get busy on other stuff? Thanks for your efforts btw.

    That said I do see this but have no idea what is means for Ubuntu (http://anonscm.debian.org/gitweb/?p=pkg-cli-apps/packages/keepass2.git;a=summary)

     
    Last edit: Scott 2013-03-02
    • David Lechner
      David Lechner
      2013-05-19

      You can subscribe to Julian's PPA to get the latest version of KeePass

      sudo apt-add-repository ppa:jtaylor/keepass
      sudo apt-get update
      sudo apt-get install keepass2
      
       
  • Miles
    Miles
    2013-07-11

    Is this PPA no longer being maintained? I tried to add the PPA to Linux Mint and it could not find it.

     
  • Miles
    Miles
    2013-07-19

    I should have specified I am using Linux Mint Debian Edition. Will the PPA work with LMDE? If not how else could I install Keepass for Debian?

     
    • David Lechner
      David Lechner
      2013-07-19

      The Debian edition may not like the Ubuntu distro names in the PPA. I am guessing that this is why it is not working.

      Other options would be to 1) Just download the portable version from the KeePass website. You would have to make your own .desktop file if you want to add it to the menu or have a desktop shortcut, but it works just fine. Or 2) Manually download and install the "experimental" package from http://packages.debian.org/experimental/keepass2

       
      • Miles
        Miles
        2013-07-20

        Thanks. I installed the 2.23 portable version. Works great and I don't have to use the PPA now on LMDE.

         
  • rob-sp
    rob-sp
    2013-08-12

    Hi, I have a problem with global auto-type. I can't get global auto-type to respond.

    I'm running linux mint 13 mate.

    I have installed the latest keepass2 from the ppa: https://launchpad.net/~jtaylor/+archive/keepass
    I have also installed xdotool which is: 2.20110530.1-3ubuntu1

    I have set a global hot key and have tried:
    mono /usr/lib/keepass2/KeePass.exe --auto-type
    /usr/lib/keepass2/KeePass.exe --auto-type
    mono /usr/bin/keepass2 --auto-type
    /usr/bin/keepass2 --auto-type

    I have my keypass2 open as a window.
    I have a test entry entitled 'pluma' with a test username and password.
    I have tried using the global auto-key in a new pluma window and nothing happens.
    Going to keepass and pressing cntrl-v does work but I really want to get the global auto-key to work.

    With a pluma window open as 'Unsaved Document 1 - pluma', I have also tried setting it as a target window.
    The target window drop down includes the window title exactly as above and I have set that. Still nothing.

    It isn't the set-up of the hotkey itself as 'mono /usr/lib/keepass2/KeePass.exe' (without '--auto-type') will happily open a new keepass instance. When I add '--auto-type', I get nothing.

    I figure it must be something to do with not matching the window titles.

    Any help would be great.

     
    Last edit: rob-sp 2013-08-12
  • Marko Schulz
    Marko Schulz
    2013-08-25

    Hello,
    about 1 month ago I've installed keepass2 for natty (11.04) via ppa:jtaylor/keepass. I know I have an older Ubuntu, but is there still a possibility to download the package keepass2 for natty (amd64) from an archive?

    Thanks & Regads
    Marko

     
    • David Lechner
      David Lechner
      2013-08-26

      No. Since 11.04 is no longer supported, I don't think anyone is going to maintain a package for it in a PPA. You can however download one of the .deb files from here. You should be able to manually install as I don't think any of the dependencies have changed in quite some time.

       
  • @rob-sp I'm running ubuntu 12.04. I used to have the same problem: ctrl-V OK but auto-type with ctrl+alt+A KO (tried keepass 2.18 from synaptic and keepass 2.24 portable). My problem was that I was too slow to type the keys! I don't know if it can be tuned but to make it work you need to type the keys very fast! I find it easier with both hands! I don't have this problem on windows. Another solution would be to stick to a 2-key combination instead of 3-key one.
    Also I would advise using the portable version instead of the "KeePass 2.x for Debian/Ubuntu Linux" (i don't know about the jtaylor version). I have some display issues on the "KeePass 2.x for Debian/Ubuntu Linux" (text field truncated, caracters typed displayed twice). Those issues are not present in the portable version.
    Hope that helps!

     
  • I thought I had it figured yesterday but again today i'm having troubles with the shortcuts! sometimes it works, sometimes not, it's hard to find the proper timing! I have found another way though: the shortcuts are more responsive when configured through compizConfig settings manager: run ccsm then search for commands...

     
  • Radar Hill
    Radar Hill
    2014-10-17

    Is the package being automatically updated to keep pace with the core project updates? Keepass has been at v2.28 for about a week but the package is still at 2.27.

     
  • Paul
    Paul
    2014-10-18

    The update process is manual.
    You can update by copying the files from the portable KeePass package over the top of your existing files - after a backup, of course.

    cheers, Paul

     
  • David Lechner
    David Lechner
    2014-10-19

    Paul, he is asking about the keepass2 package from the Ubuntu package maintainer, not the portable version. The latest Ubuntu package is found here: https://launchpad.net/~jtaylor/+archive/ubuntu/keepass/+packages

    Radar Hill, the package for version 2.28 was published on 18 Oct. 2014. And yes, it usually takes the package maintainer about a week to find time to package and release new versions.

     
  • coccobill
    coccobill
    2014-11-05

    Hi, I just upgrade keepass2 to 2.28 using this ppa in ubuntu 14.04 and I have a problem: I downloaded the backup plugin

    http://keepass.info/plugins.html#databasebackup

    but, despite the fact that the plugin should work for keepass >= 2.27, when I launch keepass2 it complains that it is not compatible.

    Any help?

    Thanks a lot

     
  • Paul
    Paul
    2014-11-05

    I'm having that problem too on my test Lubuntu set up - it's only been running since yesterday, so I'm new to using KeePass in Linux. I am trying the IOProtocolExt plug-in.

    cheers, Paul

     
  • David Lechner
    David Lechner
    2014-11-05

    Plugins on Linux require additional libraries and a mono compiler. The easiest way is to just install all things mono by running...

    apt-get install mono-complete
    

    Also, unless the plugin author specifically says that it should work on Linux/Mono, you can anticipate problems.

    And finally, it is possible for the plugin to specify that a plugin it is only compatible with a specific OS or .NET runtime version. If a plugin has specified these, it is possible that this is the source of the error message. So, if you install mono-complete and it still says that it is not compatible, this is probably why.

     
  • coccobill
    coccobill
    2014-11-06

    @david

    I installed mono-complete and the plugin works.
    Thanks for the hint.

    Maybe this piece of information is worth to be pointed out in the plugins home page.

     
<< < 1 2 3 (Page 3 of 3)