Stop stealing Focus, please.

morrty
2011-01-10
2012-11-20
  • morrty
    morrty
    2011-01-10

    Is there anyway we can have Keepass stop stealing focus? I've noticed it steals focus when you goto unlock a database or when the database actually opens. Some of my databases have bigger key transformation rounds which makes Keepass take a few seconds to open the database, in these few seconds I usually am doing other things then suddenly Keepass will steal focus and show the password popup.

     
  • Paul
    Paul
    2011-01-10

    The password pop-up is before the transforms are computed. Maybe the delay is loading the program?

    cheers, Paul

     
  • Kev
    Kev
    2011-01-10

    I think I may know what you mean. Sometimes, if Keepass is locked, I will use the shortcut ctrl-alt-k to bring Keepass into focus. I then enter my password and go back to the other program. When Keepass and completed opening the database though, it comes back into the focus. Is this what you mean? So you can enter the password and when Keepass finishes its rounds it just stays in the background?

     
  • morrty
    morrty
    2011-01-12

    @bkev
    That is exactly what I mean.

     
  • Kev
    Kev
    2011-01-12

    So having an option (if possible) like once Keepass has opened the database stay in the background?

    To replicate the behaviour, set your Keepass database to have a transformation round of a relatively high number so it takes Keepass several seconds to open/save the database. Once done, lock the database. Bring up the password prompt for Keepass, I use ctrl+alt+K and put in the password. Now, if you go to another program, web browser etc, once Keepass has completed opening the database, it will steal the focus and open over whatever it was you were doing.

    Is it possible to have an option so it doesn't do that unless the password was incorrect? (So then a prompt would steal focus saying incorrect password, otherwise you might not ever know!)