#1133 Copy password locks up GNOME and Unity

KeePass_2.x
closed
nobody
None
5
2013-07-06
2013-07-05
John
No

I use KeePass 2.2 on 4 different machines and synchronize my database with a cloud-based service so that it's current no matter which computer I use. Lately, on my work laptop running Ubuntu GNOME 13.04, double-clicking the password field to copy any given password locks up my interface. I have noticed that it happens most often after a new password has been created with the password generator. The mouse can still move, but I am unable to interact with anything on the screen and I am forced to CTRL+ALT+F2 and restart the GDM service. I was beginning to think that there was something about GNOME 3.6 that Keepass didn't like, or vice-versa. However, the issue has now cropped up on another machine running Ubuntu 13.04 with the stock Unity interface, forcing me to restart the lightdm service to regain control. I tried to see if it would lock up Windows 7, but it works flawlessly there. Please help!

Discussion

  • David Lechner
    David Lechner
    2013-07-06

    There have been a number of people that have reported this bug. It is begin tracked here: https://bugs.launchpad.net/ubuntu/+source/keepass2/+bug/1116512

    As of yet, no one has been able to reliably reproduce the bug. It just seems to happen randomly. Since it cannot be reproduced on demand, no one has been able to fix it. If you can answer items 2. and 3. in comment #9 on the bug, that could help narrow down what is going on.

     
  • Dominik Reichl
    Dominik Reichl
    2013-07-06

    • status: open --> closed
     
  • Dominik Reichl
    Dominik Reichl
    2013-07-06

    Closed as duplicate.