Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#135 Please update libtool.m4.in for amd64 support

open
nobody
None
5
2005-04-27
2005-04-27
Ben Burton
No

Hi,

The debian amd64 people have supplied a
patch that makes kbear build properly under
debian/amd64. The issue is that on debian
amd64 systems, /lib64 is a symlink to /lib, and
the "64" suffix should not be used.

Patch is attached. Note that this patch will not
adversely affect systems from other distributions
where /lib64 is a real directory.

diff
-urN ../tmp-orig/kbear-2.1.1/admin/libtool.m4.in ./admin/libtool.m4.in
--- ../tmp-orig/kbear-2.1.1/admin/libtool.m4.in
2005-03-28 10:13:22.165580416 +0200
+++ ./admin/libtool.m4.in 2005-03-28
10:12:56.532386509 +0200
@@ -1270,7 +1270,7 @@
libsuff=
if test "x$LINUX_64_MODE" = x64; then
# Some platforms are per default 64-bit, so
there's no /lib64
- if test -d /lib64; then
+ if test -d /lib64 && ! test -L /lib64; then
libsuff=64
fi
fi

Discussion

  • Ben Burton
    Ben Burton
    2005-04-27

    Logged In: YES
    user_id=146613

    Bleh, the formatting messed up the patch. I've
    attached the patch as a separate file.

     
  • Ben Burton
    Ben Burton
    2005-04-27

     
    Attachments