Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#1 make failes on Kubuntu

closed-fixed
nobody
None
5
2006-07-25
2006-07-22
Milian Wolff
No

I really want to try this exiting new plugin but can't
install it:

Here's what I do:
$ ./configure --prefix=/usr
...
Good - your configure finished. Start make now
$ make
...
make[1]: Entering directory
`/home/***/Downloads/projectmanager'
configure.in:43: error: possibly undefined macro:
AM_INIT_AUTOMAKE
If this token and others are legitimate, please
use m4_pattern_allow.
See the Autoconf documentation.
configure.in:48: error: possibly undefined macro:
AM_CONFIG_HEADER
configure.in:51: error: possibly undefined macro:
AC_CHECK_COMPILERS
configure.in:52: error: possibly undefined macro:
AC_ENABLE_SHARED
configure.in:53: error: possibly undefined macro:
AC_ENABLE_STATIC
configure.in:58: error: possibly undefined macro:
AM_KDE_WITH_NLS
configure.in:61: error: possibly undefined macro:
AC_PATH_KDE
configure.in:70: error: possibly undefined macro:
AC_CHECK_KDEMAXPATHLEN
make[1]: *** [configure] Error 1
make[1]: Leaving directory
`/home/***/Downloads/projectmanager'
make: *** [configure] Error 2

I'm not very versatile in compiling software so this
could be my mistake.
If I do another ./configure I get the following:
$ ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
./configure: line 1379: syntax error near unexpected
token `projectmanager,'
./configure: line 1379:
`AM_INIT_AUTOMAKE(projectmanager, 0.1)'

My specs:
Kubuntu 6.06 with KDE 3.5.3

Hope you can help me!

Discussion

  • lynx
    lynx
    2006-07-23

    • status: open --> pending
     
  • lars
    lars
    2006-07-23

    • status: pending --> closed-fixed
     
  • lars
    lars
    2006-07-23

    Logged In: YES
    user_id=1553129

    the problem is caused by the distri itselfs -- sulution get
    the sources, import project to kdevelop and build it by your
    own -- then it works :)

     
  • lynx
    lynx
    2006-07-23

    Logged In: YES
    user_id=1555922

    you probably just need to install automake 1.9

     
  • Milian Wolff
    Milian Wolff
    2006-07-23

    Logged In: YES
    user_id=1504668

    Ok, I needed the following packages:
    automake1.9
    kdebase-dev

    If you then use checkinstall don't forget to change the
    version number from "0.1\n01.n01.\n..." (read \n as newline)
    to a simple string (I took 1.2) - else checkinstall will
    fail building the .deb package.

    Ok, thanks to the developers, I'll now try the plugin :)

     
  • Milian Wolff
    Milian Wolff
    2006-07-23

    • status: closed-fixed --> open-fixed
     
  • lynx
    lynx
    2006-07-25

    • status: open-fixed --> closed-fixed
     
  • Logged In: NO

    My Solution for Kubuntu 6.06:

    -Install following ubuntu packet: automake1.9, kde-devel
    -Download projectmanager-0.1.2-24.tar.bz2 file
    -Unpack source: tar -xvjf projectmanager-0.1.2-24.tar.bz2 (don't use KDE ark, I had always unpacking warnings)
    -Change dir: cd projectmanager
    -Start configure: ./configure
    -Start make: make
    -Start install: sudo make install
    -Activate plugin in Kate