Jzkit V1.2 TestClient cannot connect

Help
2003-12-23
2004-01-13
  • Ivan Monnier
    Ivan Monnier
    2003-12-23

    I could not get TestClient connect to any database.

    holley:/software/ki-jzkit-1.2/TestClient $ java TestClient z3950.loc.gov 7090  usmarc Voyager "@attr 1=7 0253333490"           
    JZKit/IR Test z39.50 client $Revision: 1.39 $
    Using IR Interfaces : Information Retrieval Classes 1.2.1 Knowledge Integration Ltd.
    Connecting to z3950.loc.gov on port 7090
    1       [main] WARN  com.k_int.codec.util.OIDRegConfigurator  - Unable to find codec class : com.k_int.OpenRequest.isoill.gen.ILL_APDU_Delivery_Info.APDU_Delivery_Info_codec
    Searching
    TIME: Sub Fragment source reset
    735     [Z3950 Search Thread z3950.loc.gov] WARN  Z3950Origin  - Init was not OK, not sending outstanding queries, and failing those queries in the queue
    Private task status: Error
    Dumping result set

    The source code of Testclient was the one delivered with version 1.2 :

    holley:/software/ki-jzkit-1.2/TestClient $ ls ../src/com/k_int/z3950/IRClient/
    OutstandingOperationInfo.java  PresentCallbackHandler.java    Z3950Origin.java               ZCallbackTarget.java
    PendingSearch.java             TestClient.java                Z3950SearchTask.java
    holley:/software/ki-jzkit-1.2/TestClient $

    For sure I did something wrong, but I am unable to tell what.

     
    • Raja Kannappan
      Raja Kannappan
      2004-01-13

      Just try doing the same thing again. Even I got this error and when i tried again, it worked.

      It maybe a temporary network problem.

      - Raja.