I thought Jython 2.1 could run with JDK 1.1 or above (I'm using JDK 1.1.7B).  However, when I try to compile a Jython project, it's looking for the ReferenceQueue class which is from JDK 1.2 .  I thought I saw a 'release note' item mentioning the removal of JDK 1.2 dependencies.  I checked the JVM compatibility link:
But it mostly talks about JVM versions and not JDK versions.