hi Frank,
 
 thats good to hear :) a bit more detail (and a correction..)
   
 I tried out all of the versions of pyxml available from
    http://sourceforge.net/project/showfiles.php?group_id=6473
none of which worked when run on the code fragment below (including 0.7.1). This bug record
    http://sourceforge.net/tracker/index.php?func=detail&aid=533354&group_id=12867&atid=112867
contains an entry which says 0.7 worked, and this is still available from sourceforge*, although not linked to from above - this is the version that worked for me also.
 
code fragment:
    import xml
    a = xml.dom.minidom.parse("c:\foo.xml")
 
(the errors given vary by version, i'm afraid i haven't got a record of this)
 
it would be good if the release could ship with the latest version (ie 0.8.4) if its possible to determine why it doesn't work?
 
thanks,
Andrew
*URL munging gave:
    http://prdownloads.sourceforge.net/pyxml/PyXML-0.7.tar.gz?download

From: Frank Wierzbicki [mailto:fwierzbicki@gmail.com]
Sent: 28 September 2005 15:38
To: Andrew Ferguson
Cc: jython-users@lists.sourceforge.net
Subject: Re: [Jython-users] xml python module missing from 22alpha?



On 9/28/05, Andrew Ferguson <Andrew.Ferguson@arm.com> wrote:
hi,
 
 i've noticed that
 
    <Jython22a>/lib/xml
 
is not present in the 22alpha. Downloading various versions of pyxml shows that functionality from xml.dom.minidom does not work except with 7.1.
 
was the xml directory intentionally removed?

I don't think it was intentionally removed.  In any case we intend to get it in there before we release.  Thanks for the research, I'll look at 7.1 first when I try to get it bundled.

-Frank